Multi-Carrier Group Delay (R&S FSW-K17)
Contents
  • Welcome to the Multi-Carrier Group Delay Application
  • About the Measurement
  • Measurements and Result Display
  • Measurement Basics
  • Configuration
  • Analysis
  • Importing and Exporting Results
  • How to Perform Measurements in the Multi-Carrier Group Delay Application
  • Optimizing and Troubleshooting the Measurement
  • Remote Commands to Perform Multi-Carrier Group Delay Measurements
  • Annex
  • List of Commands
Top


Welcome to the Multi-Carrier Group Delay Application

Multi-Carrier Group Delay (R&S FSW-K17) > Welcome to the Multi-Carrier Group Delay Application
Welcome to the Multi-Carrier Group Delay Application

The R&S FSW-K17 option is a firmware application that adds functionality to perform Multi-Carrier Group Delay measurements to the R&S FSW.

The Multi-Carrier Group Delay application features:

  • highly accurate group delay measurement for large spans
  • orthogonal measurement method
  • frequency converted group delay measurement
  • storage and loading functions for reference data
  • storage functions for measurement settings and results
  • graphical display of:
    – group delay
    – magnitude and phase at carrier frequency points in measurement or reference signal
  • interactive or remote measurement control

This user manual contains a description of the functionality that the application provides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are described in the R&S FSW User Manual. The latest version is available for download at the product homepage.

Installation

You can find detailed installation instructions in the R&S FSW Getting Started manual or in the Release Notes.

Contents
  • Starting the Multi-Carrier Group Delay Application
  • Understanding the Display Information


Starting the Multi-Carrier Group Delay Application

Multi-Carrier Group Delay (R&S FSW-K17) > Welcome to the Multi-Carrier Group Delay Application > Starting the Multi-Carrier Group Delay Application
Starting the Multi-Carrier Group Delay Application

The Multi-Carrier Group Delay application adds a new measurement to the R&S FSW.

To activate the Multi-Carrier Group Delay application

  1. Press the MODE key on the front panel of the R&S FSW.

    A dialog box opens that contains all operating modes and applications currently available on your R&S FSW.

  2. Select the "MC Group Delay" item.

    The R&S FSW opens a new measurement channel for the Multi-Carrier Group Delay application.

For details see "Operating Modes" .

The measurement is started immediately with the default settings. It can be configured in the Multi-Carrier Group Delay "Overview" dialog box, which is displayed when you select the "Overview" softkey from any menu (see "Configuration Overview").

Multiple Measurement Channels and Sequencer Function

When you activate an application, a new measurement channel is created which determines the measurement settings for that application. The same application can be activated with different measurement settings by creating several channels for the same application.

The number of channels that can be configured at the same time depends on the available memory on the instrument.

Only one measurement can be performed at any time, namely the one in the currently active channel. However, in order to perform the configured measurements consecutively, a Sequencer function is provided.

If activated, the measurements configured in the currently active channels are performed one after the other in the order of the tabs. The currently active measurement is indicated by a [image] symbol in the tab label. The result displays of the individual channels are updated in the tabs (including the "MultiView") as the measurements are performed. Sequential operation itself is independent of the currently displayed tab.

For details on the Sequencer function see "Running a Sequence of Measurements" .


Understanding the Display Information

Multi-Carrier Group Delay (R&S FSW-K17) > Welcome to the Multi-Carrier Group Delay Application > Understanding the Display Information
Understanding the Display Information

The following figure shows a measurement diagram during analyzer operation. All different information areas are labeled. They are explained in more detail in the following sections.

1 = Channel bar for firmware and measurement settings
2+3 = Window title bar with diagram-specific (trace) information
4 = Diagram area
5 = Diagram footer with diagram-specific information, depending on evaluation
6 = Instrument status bar with error messages, progress bar and date/time display
Channel bar information

In the Multi-Carrier Group Delay application, the R&S FSW shows the following settings:

Information displayed in the channel bar in the Multi-Carrier Group Delay application
Ref Level | Reference level
Att | Mechanical and electronic RF attenuation
Offset | Reference level offset
Freq | Center frequency for the RF signal
Meas Time | Measurement time
Span | Measurement bandwidth
Last Ref Cal | Timestamp of most recently performed reference calibration (if it has already been performed)
Ref Cal Freq | Frequency used for reference calibration
Group Delay | Mode of group delay result display (absolute or relative)
Carrier Offset | Offset of the carrier from the center frequency

In addition, the channel bar also displays information on instrument settings that affect the measurement results even though this is not immediately apparent from the display of the measured values (e.g. transducer or trigger settings). This information is displayed only when applicable for the current measurement. For details see the R&S FSW Getting Started manual.

Window title bar information

For each diagram, the header provides the following information:

Window title bar information in Multi-Carrier Group Delay application
1 = Window number
2 = Window type
3 = Trace color
4 = Trace number
5 = Trace mode
Diagram footer information

The diagram footer (beneath the diagram) contains the center frequency and span and the range displayed per division.

Status bar information

Global instrument settings, the instrument status and any irregularities are indicated in the status bar beneath the diagram. Furthermore, the progress of the current operation is displayed in the status bar.


About the Measurement

Multi-Carrier Group Delay (R&S FSW-K17) > About the Measurement
About the Measurement
Frequency delay in transmitted signals

All frequency components of a signal are delayed when passed through a device such as an amplifier, a loudspeaker, or propagated through space or a medium, such as air. This signal delay will be different for the various frequencies unless the device has the property of being linear phase. The delay variation means that signals consisting of multiple frequency components will suffer distortion because these components are not delayed by the same amount of time at the output of the device. This changes the shape of the signal in addition to any constant delay, which can result in a signal that no longer matches the receiver filter, which in turn results in degraded Signal to Noise Ratio (SNR) or Bit Error Rate (BER).

Group delay as a characterization of transmission components

The delay of all frequencies together is referred to as the group delay and can be used to characterize the quality of transmission for such components. Group delay is also a measure of how long it takes for a signal's information to propagate through a channel or device under test.

Since digital modulation schemes in which the frequency plays an important role are very common, the group delay is of special interest to all manufacturers or testers of transmission components, as well as frequency converters. Satellite transponders, for example, need to be characterized by the phase transmission in addition to the amplitude transmission. Both values can be determined precisely and easily with the R&S FSW Multi-Carrier Group Delay application.

The Multi-Carrier Group Delay measurement method

The R&S FSW Multi-Carrier Group Delay application evaluates an input signal provided by a signal generator. After a preliminary reference measurement of this signal without the device under test, the same signal is evaluated with the device subsequently. Instead of evaluating the timing of the signals, the phase shift and magnitude response of multiple carriers across frequency is measured. A baseband signal consisting of several unmodulated carriers with a fixed step size is used as an input signal, allowing for a very quick wideband measurement. By measuring the phase differences between the two signals at the input and at the output, the application calculates the relative phase between output and input.

However, the phase of the carriers at the input to the DUT does not actually have to be measured. Instead, the results are normalized. That way, no reference path or connection is needed between the input and the output of the DUT. A reference mixer in the signal generator provides a phase reference at the IF frequency. Thus, a constant delay factor is eliminated and the group delay is calculated relative to the reference signal.

If an external trigger is used, the absolute group delay can also be calculated. Absolute group delay is of interest for instance to equalize the delay of two channels, characterize cables and design quadrature FM demodulators.

Multi-Carrier Group Delay Measurement Setup


Measurements and Result Display

Multi-Carrier Group Delay (R&S FSW-K17) > Measurements and Result Display
Measurements and Result Display

The data that was measured by the R&S FSW can be evaluated using various different methods. In the Multi-Carrier Group Delay application, up to 6 evaluation methods can be displayed simultaneously in separate windows.

All results are determined from the I/Q data set captured for the measurement.

Storing Results

The results of the Multi-Carrier Group Delay measurement can be stored to a file, either in CSV or ASCII format. The results of the calibration (reference) measurement can also be stored in CSV format.

Contents
  • Evaluation Methods for Multi-Carrier Group Delay


Evaluation Methods for Multi-Carrier Group Delay

Multi-Carrier Group Delay (R&S FSW-K17) > Measurements and Result Display > Evaluation Methods for Multi-Carrier Group Delay
Evaluation Methods for Multi-Carrier Group Delay

The following evaluation methods can be selected for Multi-Carrier Group Delay measurements.

└ Magnitude
└ Phase
└ Magnitude Reference
└ Phase Reference
└ Group Delay
└ Gain
└ Marker Table


Magnitude

Multi-Carrier Group Delay (R&S FSW-K17) > Measurements and Result Display > Evaluation Methods for Multi-Carrier Group Delay > Magnitude
Magnitude

Displays the spectrum of the input signal. In contrast to the Spectrum application, the frequency values are determined using an Discrete frequency transformation (DFT) from the recorded I/Q data set.

Remote command:

LAY:ADD? '1',RIGH,MAGN

(see LAYout:​ADD[:​WINDow]?)


Phase

Multi-Carrier Group Delay (R&S FSW-K17) > Measurements and Result Display > Evaluation Methods for Multi-Carrier Group Delay > Phase
Phase

Displays the phase deviations of the measured signal (in rad or °) versus frequency.

Remote command:

LAY:ADD? '1',RIGH,PHAS

(see LAYout:​ADD[:​WINDow]?)


Magnitude Reference

Multi-Carrier Group Delay (R&S FSW-K17) > Measurements and Result Display > Evaluation Methods for Multi-Carrier Group Delay > Magnitude Reference
Magnitude Reference

Displays the spectrum of the reference signal. In contrast to the Spectrum application, the frequency values are determined using DFT from the recorded I/Q data set.

Remote command:

LAY:ADD? '1',RIGH,RMAG

(see LAYout:​ADD[:​WINDow]?)


Phase Reference

Multi-Carrier Group Delay (R&S FSW-K17) > Measurements and Result Display > Evaluation Methods for Multi-Carrier Group Delay > Phase Reference
Phase Reference

Displays the phase deviations of the reference signal (in rad or °) versus frequency.

Remote command:

LAY:ADD? '1',RIGH,RPH

(see LAYout:​ADD[:​WINDow]?)


Group Delay

Multi-Carrier Group Delay (R&S FSW-K17) > Measurements and Result Display > Evaluation Methods for Multi-Carrier Group Delay > Group Delay
Group Delay

Displays the time deviations of the signal versus frequency.

Note: This result display requires a calibration measurement (see "Calibrate (Execute Reference Calibration)").

Remote command:

LAY:ADD? '1',RIGH,GRPD

(see LAYout:​ADD[:​WINDow]?)


Gain

Multi-Carrier Group Delay (R&S FSW-K17) > Measurements and Result Display > Evaluation Methods for Multi-Carrier Group Delay > Gain
Gain

Displays the gain in magnitude from the reference trace to the measurement trace in dB or percent. This diagram characterizes the transmission behavior of the DUT.

Note: This result display requires a calibration measurement (see "Calibrate (Execute Reference Calibration)").

Remote command:

LAY:ADD? '1',RIGH,GAIN

(see LAYout:​ADD[:​WINDow]?)


Marker Table

Multi-Carrier Group Delay (R&S FSW-K17) > Measurements and Result Display > Evaluation Methods for Multi-Carrier Group Delay > Marker Table
Marker Table

Displays a table with the current marker values for the active markers.

This table may be displayed automatically if configured accordingly (see "Marker Table Display").

Remote command:

LAY:ADD? '1',RIGH, MTAB, see LAYout:​ADD[:​WINDow]?

Results:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?


Measurement Basics

Multi-Carrier Group Delay (R&S FSW-K17) > Measurement Basics
Measurement Basics

Some background knowledge on basic terms and principles used in Multi-Carrier Group Delay measurements is provided here for a better understanding of the required configuration settings.

Contents
  • Definitions
  • The Multi-Carrier Measurement
  • The Calibration (Reference) Measurement
  • Measurement Setup
  • Trace Smoothing


Definitions

Multi-Carrier Group Delay (R&S FSW-K17) > Measurement Basics > Definitions
Definitions
Group delay

Group delay is a measure of phase distortion and defined as the derivation of phase over frequency:

Gain (Magnitude flatness)

The gain (also referred to as the magnitude flatness or amplitude flatness) is defined as the relation between the measured magnitude and the reference (calibration) magnitude:

The gain describes the transmission behavior of the DUT.


The Multi-Carrier Measurement

Multi-Carrier Group Delay (R&S FSW-K17) > Measurement Basics > The Multi-Carrier Measurement
The Multi-Carrier Measurement

The R&S FSW Multi-Carrier Group Delay application evaluates an input signal provided by a signal generator. A signal consisting of several unmodulated carriers with a fixed step size is used as an input signal.

Dependancy of the span on the number of carriers

The frequency span to be swept during the measurement is determined by the number of carriers in the input signal and the spacing between them. It is recommended that you set the span according to the following equation:

Span = (Number of carriers -1) * carrier spacing (Δf)

Example:

A span ≥ 3 * carrier spacing (Δf) is required to measure a signal with four carriers.

As a rule, the span can only be defined as a multiple of the carrier spacing.

Center frequency and carrier offset

If the carriers are not aligned with the defined center frequency, the offset can be estimated automatically; the carrier frequencies with the fixed offset are then used to improve the calculation.

Carrier estimation

If the carrier frequencies are distorted due to the Doppler-effect, the frequencies for each carrier can be estimated, thus improving the results of the group delay.

Demodulation bandwidth

The bandwidth to be demodulated during the measurement is determined automatically by the application from the defined span and carrier spacing.

Measurement time

The required duration of the measurement can be determined automatically by the application according to the defined carrier spacing and span, or it can be configured manually.

Averaging results

The calculated values can be averaged over several sweeps in order to obtain more reliable results.

Orthogonal calculation method

The orthogonal calculation method aligns the trace points in the result display to the carrier frequencies of the input signal. To do so, a DFT window length equaling 1/Δf is used.

Absolute vs relative group delay

The group delay is calculated relative to the reference signal, eliminating any constant delay factors. If an external trigger is used, the absolute group delay can also be calculated.


The Calibration (Reference) Measurement

Multi-Carrier Group Delay (R&S FSW-K17) > Measurement Basics > The Calibration (Reference) Measurement
The Calibration (Reference) Measurement

The Multi-Carrier Group Delay measurement method requires a preliminary reference measurement of the input signal without the device under test before the actual group delay measurement. This reference measurement is also referred to as the calibration measurement. The results of this measurement are stored internally in the R&S FSW to be used as a reference for the group delay calculation in the subsequent measurement with the DUT.

The results of the calibration measurement can be stored to a file and loaded as reference data for future measurements with the same setup.

The date and time of the most recently performed or loaded calibration measurement is indicated in the channel bar.


Measurement Setup

Multi-Carrier Group Delay (R&S FSW-K17) > Measurement Basics > Measurement Setup
Measurement Setup

Before a Multi-Carrier Group Delay measurement can be performed, the R&S FSW must be set up in a test environment. This section describes the required settings of the R&S FSW. Before starting the measurements, the R&S FSW has to be configured correctly and supplied with power as described in the R&S FSW Getting Started manual, "Preparing For Use". Furthermore, the application firmware R&S FSW-K17 must be enabled. Installation and enabling of the application firmware are described in the R&S FSW Getting Started manual or in the Release Notes.

A Multi-Carrier Group Delay measurement requires the following devices:

  • A baseband signal generator, e.g. a Vector Signal Generator R&S SMU
  • The R&S FSW with application firmware R&S FSW-K17: Multi-Carrier Group Delay
  • The device under test to be analyzed
►

Connect the signal generator output to the RF INPUT connector of the R&S FSW - first without the DUT, then with the DUT inbetween.

For absolute group delay measurement, connect the trigger output of the signal generator to one of the trigger inputs (TRIGGER INPUT) of the R&S FSW (see "Trigger 2/3").

Multi-Carrier Group Delay test setup

It is recommended that you use an input signal with a low crest factor to get the phase response of the DUT. Furthermore, an external frequency reference is recommended for high accuracy measurements.

The following list summarizes the necessary measurement and calculation steps:

  1. Calibration measurement without DUT:

    φcal(k)

  2. Measurement with DUT:

    φmeas(k)

  3. Evaluate group delay:


Trace Smoothing

Multi-Carrier Group Delay (R&S FSW-K17) > Measurement Basics > Trace Smoothing
Trace Smoothing

Smoothing is a way to visually remove anomalies in the trace (like spurs) that may distort the results. The smoothing process is based on a moving average over the complete measurement range. The number of samples included in the averaging process (the aperture size) is variable and is a percentage of all samples that the trace consists of.

Sample size included in trace smoothing

The application smoothes the trace only after the measurement has been finished and the data has been analyzed and written to a trace. Thus, smoothing is really just an enhancement of the trace display, not of the data itself. This also means that smoothing is always applied after any other trace averagings have been done, as these happen during the measurement itself. You can turn trace smoothing on and off for all traces individually and compare, for example, the raw and the smooth trace.

Linear smoothing is based on the following algorithm:

Linear trace smoothing

with:

s = sample number

y(s) = group delay

x = sample offset from s

n = aperture size


Configuration

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration
Configuration
Multi-Carrier Group Delay Application

Multi-Carrier Group Delay measurements require a special application on the R&S FSW, which you activate using the MODE key on the front panel.

For details see "Applications and Operating Modes" .

When you switch the application of a measurement channel to Multi-Carrier Group Delay application the first time, a set of parameters is passed on from the currently active application (see "Default Settings for Multi-Carrier Group Delay measurements"). After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

When you activate a measurement channel in Multi-Carrier Group Delay application, a Multi-Carrier Group Delay measurement for the input signal is started automatically with the default configuration. The "MCGD Meas" menu is displayed and provides access to the most important configuration functions.

MCGD measurement in MSRT mode

When you switch to MSRT mode, the Sequencer is automatically activated in Continuous Sequence mode. Since the default trigger mode is "Free Run" and "Auto Rearm", the MSRT Master continuously performs a realtime measurement until it is stopped. During this time, the Sequencer never passes the data on to other MSRT applications and no evaluation is performed in those result displays.

Thus, it is important that you configure a trigger for the MSRT Master, or stop the Sequencer and switch between the Master and the application tabs manually. In this case, the continuous measurement is stopped when you switch tabs. However, you will have to update the subsequent application displays manually, using the "Refresh" functions (see "Refresh" /"Refresh All" ).

For details see "Configuring and Performing Measurements in MSRT Mode" .

For a description see
  • "Carrier Spacing"
  • "Group Delay Mode"
  • "Measurement Time"
  • "Calibrate (Execute Reference Calibration)"
  • "Multi-Carrier Configuration"
  • "Display Configuration"

The "Lines", "AUTO SET", and "Marker Funct" menus are currently not used.

Contents
  • Default Settings for Multi-Carrier Group Delay measurements
  • Configuration Overview
  • Input Source Settings
  • Amplitude and Y-Axis Scaling
  • Frequency Settings
  • Trigger Settings
  • Multi-Carrier Configuration
  • Sweep Settings
  • Output Settings
  • Automatic Settings


Default Settings for Multi-Carrier Group Delay measurements

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Default Settings for Multi-Carrier Group Delay measurements
Default Settings for Multi-Carrier Group Delay measurements

When you switch the application of a measurement channel to Multi-Carrier Group Delay application the first time, a set of parameters is passed on from the currently active application:

  • center frequency and center frequency offset
  • reference level and reference level offset
  • attenuation

After initial setup, the parameters for the measurement channel are stored upon exiting and restored upon re-entering the channel. Thus, you can switch between applications quickly and easily.

Apart from these settings, the following default settings are activated directly after a measurement channel has been set to Multi-Carrier Group Delay application, or after a "Preset Channel":

Default settings for Multi-Carrier Group Delay channels
Parameter | Value
Span | 10.0 MHz
Sweep mode | CONTINUOUS
Trigger settings | FREE RUN
Trigger offset | 0
Carrier Spacing | 200 kHz
Measurement time | 25 ms (manual)
Sweep count | 0
Group Delay mode | absolute
Traces | 1: Clr/Write, 2-4: blank
Evaluations | Window 1: Magnitude Window 2: Phase Window 3: Group Delay


Configuration Overview

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Configuration Overview
Configuration Overview

Throughout the measurement channel configuration, an overview of the most important currently defined settings is provided in the "Overview". The "Overview" is displayed when you select the "Overview" icon, which is available at the bottom of all softkey menus.

In addition to the main measurement settings, the "Overview" provides quick access to the main settings dialog boxes. The individual configuration steps are displayed in the order of the data flow. Thus, you can easily configure an entire measurement channel from input over processing to output and analysis by stepping through the dialog boxes as indicated in the "Overview".

In particular, the "Overview" provides quick access to the following configuration dialog boxes (listed in the recommended order of processing):

  1. Input Settings

    See "Input Source Settings"

  2. Amplitude Settings

    See "Amplitude and Y-Axis Scaling"

  3. Frequency Settings

    See "Frequency Settings"

  4. Trigger Settings

    See "Trigger Settings"

  5. Multi-Carrier Configuration

    See "Multi-Carrier Configuration"

  6. Output Settings

    See "Output Settings"

  7. Analysis

    See "Analysis"

  8. Display Configuration

    See "Display Configuration"

The main configuration settings and dialog boxes are also available via the "MCGD Meas" menu which is displayed when you press the MEAS CONFIG key.

For a description see
  • "Carrier Spacing"
  • "Group Delay Mode"
  • "Measurement Time"
  • "Calibrate (Execute Reference Calibration)"
  • "Measurement Configuration"
  • "Display Configuration"
To configure settings
►

Select any button in the "Overview" to open the corresponding dialog box.

Select a setting in the channel bar (at the top of the measurement channel tab) to change a specific setting.

For step-by-step instructions on configuring Multi-Carrier Group Delay measurements, see "How to Perform Measurements in the Multi-Carrier Group Delay Application".

└ Preset Channel
└ Specifics for


Preset Channel

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Configuration Overview > Preset Channel
Preset Channel

Select the "Preset Channel" button in the lower lefthand corner of the "Overview" to restore all measurement settings in the current channel to their default values.

Note that the PRESET key on the front panel restores the entire instrument to its default values and thus closes all measurement channels on the R&S FSW (except for the default Spectrum application channel)!

See "Default Settings for Multi-Carrier Group Delay measurements" for details.

Remote command:

SYSTem:​PRESet:​CHANnel[:​EXECute]


Specifics for

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Configuration Overview > Specifics for
Specifics for

The measurement channel may contain several windows for different results. Thus, the settings indicated in the "Overview" and configured in the dialog boxes vary depending on the selected window.

Select an active window from the "Specifics for" selection list that is displayed in the "Overview" and in all window-specific configuration dialog boxes.

The "Overview" and dialog boxes are updated to indicate the settings for the selected window.


Input Source Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Input Source Settings
Input Source Settings

The input source determines which data the R&S FSW will analyze.

Input settings can be configured in the "Input" dialog box.

Some settings are also available in the "Amplitude" tab of the "Amplitude" dialog box.

Output settings are described in "Output Settings".

The Digital I/Q and the Analog Baseband input sources are only available in applications that support I/Q data processing and are described in detail in "Basics on I/Q Data Acquisition and Processing" .

Contents
  • Radio Frequency Input


Radio Frequency Input

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Input Source Settings > Radio Frequency Input
Radio Frequency Input

The default input source for the R&S FSW is "Radio Frequency", i.e. the signal at the RF INPUT connector on the front panel of the R&S FSW. If no additional options are installed, this is the only available input source.

└ Input Coupling
└ Impedance
└ High-Pass Filter 1...3 GHz
└ YIG-Preselector


Input Coupling

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Input Source Settings > Radio Frequency Input > Input Coupling
Input Coupling

The RF input of the R&S FSW can be coupled by alternating current (AC) or direct current (DC).

AC coupling blocks any DC voltage from the input signal. This is the default setting to prevent damage to the instrument. Very low frequencies in the input signal may be distorted.

However, some specifications require DC coupling. In this case, you must protect the instrument from damaging DC input voltages manually. For details, refer to the data sheet.

Remote command:

INPut:​COUPling


Impedance

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Input Source Settings > Radio Frequency Input > Impedance
Impedance

The reference impedance for the measured levels of the R&S FSW can be set to 50 Ω or 75 Ω.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a 75 Ω adapter of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Remote command:

INPut:​IMPedance


High-Pass Filter 1...3 GHz

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Input Source Settings > Radio Frequency Input > High-Pass Filter 1...3 GHz
High-Pass Filter 1...3 GHz

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Remote command:

INPut:​FILTer:​HPASs[:​STATe]


YIG-Preselector

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Input Source Settings > Radio Frequency Input > YIG-Preselector
YIG-Preselector

Activates or deactivates the YIG-preselector.

An internal YIG-preselector at the input of the R&S FSW ensures that image frequencies are rejected. However, this is only possible for a restricted bandwidth. In order to use the maximum bandwidth for signal analysis you can deactivate the YIG-preselector at the input of the R&S FSW, which may lead to image-frequency display.

Note that the YIG-preselector is active only on frequencies greater than 8 GHz. Therefore, switching the YIG-preselector on or off has no effect if the frequency is below that value.

Note:

For the following measurements, the YIG-Preselector is off by default (if available).
  • I/Q Analyzer (and thus in all applications in MSRA operating mode)
  • Multi-Carrier Group Delay
  • GSM
  • VSA

Remote command:

INPut:​FILTer:​YIG[:​STATe]


Amplitude and Y-Axis Scaling

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling
Amplitude and Y-Axis Scaling

The amplitude and y-axis scaling are configured in the "Amplitude" dialog box. Amplitude settings are identical to the base unit.

See "Amplitude Settings".

►

To display this dialog box, do one of the following:

  • Select the "Amplitude" button in the "Overview".
  • Select the AMPT key and then the "Amplitude Config" softkey.
Contents
  • Amplitude Settings
  • Scaling the Y-Axis
  • Units


Amplitude Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Amplitude Settings
Amplitude Settings

Amplitude settings determine how the R&S FSW must process or display the expected input power levels.

To configure the amplitude settings

Amplitude settings can be configured via the AMPT key or in the "Amplitude" dialog box.

►

To display the "Amplitude" dialog box, do one of the following:

  • Select "Input/Frontend" from the "Overview" and then switch to the "Amplitude" tab.
  • Select the AMPT key and then the "Amplitude Config" softkey.
└ Reference Level
└ Shifting the Display (Offset)
└ RF Attenuation
└ Attenuation Mode / Value
└ Using Electronic Attenuation (Option B25)
└ Input Settings
└ Preamplifier (option B24)
└ Input Coupling
└ Impedance
└ Range


Reference Level

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Amplitude Settings > Reference Level
Reference Level

Defines the expected maximum reference level. Signal levels above this value may not be measured correctly, which is indicated by the "IF OVLD" status display.

The reference level is also used to scale power diagrams; the reference level is then used as the maximum on the y-axis.

Since the R&S FSW hardware is adapted according to this value, it is recommended that you set the reference level close above the expected maximum signal level to ensure an optimum measurement (no compression, good signal-to-noise ratio).

Note that the "Reference Level" value ignores the "Shifting the Display (Offset)". It is important to know the actual power level the R&S FSW must handle.

For details see "Reference Level" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel

└ Shifting the Display (Offset)


Shifting the Display (Offset)

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Amplitude Settings > Reference Level > Shifting the Display (Offset)
Shifting the Display (Offset)

Defines an arithmetic level offset. This offset is added to the measured level irrespective of the selected unit. The scaling of the y-axis is changed accordingly.

Define an offset if the signal is attenuated or amplified before it is fed into the R&S FSW so the application shows correct power results. All displayed power level results will be shifted by this value.

Note, however, that the "Reference Level" value ignores the "Reference Level Offset". It is important to know the actual power level the R&S FSW must handle.

To determine the required offset, consider the external attenuation or gain applied to the input signal. A positive value indicates that an attenuation took place (R&S FSW increases the displayed power values) , a negative value indicates an external gain (R&S FSW decreases the displayed power values).

The setting range is ±200 dB in 0.01 dB steps.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RLEVel:​OFFSet


RF Attenuation

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Amplitude Settings > RF Attenuation
RF Attenuation

Defines the attenuation applied to the RF input.

└ Attenuation Mode / Value


Attenuation Mode / Value

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Amplitude Settings > RF Attenuation > Attenuation Mode / Value
Attenuation Mode / Value

The RF attenuation can be set automatically as a function of the selected reference level (Auto mode). This ensures that the optimum RF attenuation is always used. It is the default setting. By default and when "Using Electronic Attenuation (Option B25)" is not available, mechanical attenuation is applied.

In "Manual" mode, you can set the RF attenuation in 1 dB steps (down to 0 dB, also using the rotary knob). Other entries are rounded to the next integer value. The range is specified in the data sheet. If the defined reference level cannot be set for the defined RF attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed.

NOTICE! Risk of hardware damage due to high power levels. When decreasing the attenuation manually, ensure that the power level does not exceed the maximum level allowed at the RF input, as an overload may lead to hardware damage.

Note: In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible (if option B25 is installed and active) to reduce the amount of mechanical switching required.

For details see "RF Attenuation" .

Remote command:

INPut:​ATTenuation

INPut:​ATTenuation:​AUTO


Using Electronic Attenuation (Option B25)

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Amplitude Settings > Using Electronic Attenuation (Option B25)
Using Electronic Attenuation (Option B25)

If option R&S FSW-B25 is installed, you can also activate an electronic attenuator.

In "Auto" mode, the settings are defined automatically; in "Manual" mode, you can define the mechanical and electronic attenuation separately.

Note: Electronic attenuation is not available for stop frequencies (or center frequencies in zero span) >13.6 GHz.
In "Auto" mode, RF attenuation is provided by the electronic attenuator as much as possible to reduce the amount of mechanical switching required. Mechanical attenuation may provide a better signal-to-noise ratio, however.
When you switch off electronic attenuation, the RF attenuation is automatically set to the same mode (auto/manual) as the electronic attenuation was set to. Thus, the RF attenuation may be set to automatic mode, and the full attenuation is provided by the mechanical attenuator, if possible.

Both the electronic and the mechanical attenuation can be varied in 1 dB steps. Other entries are rounded to the next lower integer value.

If the defined reference level cannot be set for the given attenuation, the reference level is adjusted accordingly and the warning "Limit reached" is displayed in the status bar.

Remote command:

INPut:​EATT:​STATe

INPut:​EATT:​AUTO

INPut:​EATT


Input Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Amplitude Settings > Input Settings
Input Settings

Some input settings affect the measured amplitude of the signal, as well.

└ Preamplifier (option B24)
└ Input Coupling
└ Impedance
└ Range


Preamplifier (option B24)

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Amplitude Settings > Input Settings > Preamplifier (option B24)
Preamplifier (option B24)

If option R&S FSW-B24 is installed, a preamplifier can be activated for the RF input signal.

You can use a preamplifier to analyze signals from DUTs with low input power.

For R&S FSW 26 or higher models, the input signal is amplified by 30 dB if the preamplifier is activated.

For R&S FSW 8 or 13 models, the following settings are available:

"Off" | Deactivates the preamplifier.
"15 dB" | The RF input signal is amplified by about 15 dB.
"30 dB" | The RF input signal is amplified by about 30 dB.
Remote command:

INPut:​GAIN:​STATe

INPut:​GAIN[:​VALue]


Range

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Amplitude Settings > Input Settings > Range
Range

Defines the displayed y-axis range in dB.

The default value is 100 dB.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]


Scaling the Y-Axis

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis
Scaling the Y-Axis

The individual scaling settings that affect the vertical axis are described here.

Note that scaling settings are window-specific, as opposed to the amplitude settings. Depending on the result display, different methods of defining the scaling are available.

└ Defining a Range and the Reference Level Position
└ Range
└ Ref Level Position
└ Scaling
└ Configuring a Reference Point and Divisions
└ Y-Axis Reference Value
└ Y-Axis Reference Position
└ Range per Division
└ Defining Min and Max Values
└ Scale Mode


Defining a Range and the Reference Level Position

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis > Defining a Range and the Reference Level Position
Defining a Range and the Reference Level Position

For Magnitude displays, you can define the position of the reference level (for linear scaling), or define the range in dB and the position of the reference level.

└ Range
└ Ref Level Position
└ Scaling


Ref Level Position

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis > Defining a Range and the Reference Level Position > Ref Level Position
Ref Level Position

Defines the reference level position, i.e. the position of the maximum AD converter value on the level axis in %, where 0 % corresponds to the lower and 100 % to the upper limit of the diagram.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Scaling

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis > Defining a Range and the Reference Level Position > Scaling
Scaling

Defines the scaling method for the y-axis.

For more information see "Scaling" .

"Logarithmic" | Logarithmic scaling (only available for logarithmic units - dB..., and A, V, Watt)
"Linear Unit" | Linear scaling in the unit of the measured signal
"Linear Percent" | Linear scaling in percentages from 0 to 100
"Absolute" | The labeling of the level lines refers to the absolute value of the reference level (not available for "Linear Percent")
"Relative" | The scaling is in dB, relative to the reference level (only available for logarithmic units - dB...). The upper line of the grid (reference level) is always at 0 dB.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE


Configuring a Reference Point and Divisions

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis > Configuring a Reference Point and Divisions
Configuring a Reference Point and Divisions

Defines the displayed range using a reference point and the size of the divisions.

For details on the different methods to configure the scaling see "How to Change the Display Scaling" .

└ Y-Axis Reference Value
└ Y-Axis Reference Position
└ Range per Division


Y-Axis Reference Value

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis > Configuring a Reference Point and Divisions > Y-Axis Reference Value
Y-Axis Reference Value

Defines a reference value for the y-axis in the current unit. The y-axis is adapted so that the reference value is displayed at the "Y-Axis Reference Position".

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RVALue


Y-Axis Reference Position

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis > Configuring a Reference Point and Divisions > Y-Axis Reference Position
Y-Axis Reference Position

Defines the position of the "Y-Axis Reference Value" on the y-axis. The position is defined as a percentage value, where 0 % refers to the bottom edge, 100 % refers to the top edge of the screen. The y-axis is adapted so that the reference value is displayed at the reference position.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​RPOSition


Range per Division

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis > Configuring a Reference Point and Divisions > Range per Division
Range per Division

Defines the value range to be displayed per division. Since the display consists of 10 divisions by default, the displayed range is:

Range = 10 * <Range per Division>

Note: If fewer divisions are displayed (e.g. because the window is reduced in height), the range per division is increased in order to display the same result range in the smaller window. In this case, the range per division does not correspond to the actual display.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​PDIVision


Defining Min and Max Values

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis > Defining Min and Max Values
Defining Min and Max Values

Defines the displayed range using minimum and maximum values.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MINimum

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MAXimum


Scale Mode

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Scaling the Y-Axis > Scale Mode
Scale Mode

For Gain display only: Defines the scaling method for the y-axis.

For more information see "Scaling" .

"Logarithmic" | Logarithmic scaling (only available for logarithmic units - dB...)
"Linear" | Linear scaling in percentages from 0 to 100
Remote command:

DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]:​MODE


Units

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Units
Units

The units define how the demodulated data is displayed. They are configured in the "Units" tab of the "Amplitude" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Amplitude" button in the Analog Demodulation "Overview" and select the "Units" tab.
  • Select the MEAS CONFIG key and then the "Unit Config" softkey.
└ Phase Unit (Rad/Deg)


Phase Unit (Rad/Deg)

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Amplitude and Y-Axis Scaling > Units > Phase Unit (Rad/Deg)
Phase Unit (Rad/Deg)

Sets the phase unit to rad or deg for displaying phase signals.

Remote command:

UNIT:​ANGLe


Frequency Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Frequency Settings
Frequency Settings

Frequency settings for the input signal can be configured via the "Frequency" dialog box, which is displayed when you do one of the following:

  • Select the FREQ key and then the "Frequency Config" softkey.
  • Select "Frequency" in the configuration "Overview".
└ Center frequency
└ Span
└ Center Frequency Stepsize
└ Frequency Offset


Center frequency

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Frequency Settings > Center frequency
Center frequency

Defines the normal center frequency of the signal. The allowed range of values for the center frequency depends on the frequency span.

fmax and spanmin are specified in the data sheet.

Remote command:

[SENSe:​]FREQuency:​CENTer


Span

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Frequency Settings > Span
Span

Defines the frequency span to be measured. Only a multiple of the carrier spacing can be defined. The "Number of Carriers" is adapted accordingly (see "Dependancy of the span on the number of carriers").

Remote command:

[SENSe:​]FREQuency:​SPAN


Center Frequency Stepsize

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Frequency Settings > Center Frequency Stepsize
Center Frequency Stepsize

Defines the step size by which the center frequency is increased or decreased when the arrow keys are pressed. When you use the rotary knob the center frequency changes in steps of only 1/10 of the "Center Frequency Stepsize".

The step size can be coupled to another value or it can be manually set to a fixed value.

For more details see "Stepping Through the Frequency Range - Center Frequency Stepsize" .

"X * Span" | Sets the step size for the center frequency to a defined factor of the span. The "X-Factor" defines the percentage of the span. Values between 1 and 100 % in steps of 1 % are allowed. The default setting is 10 %.
"= Center" | Sets the step size to the value of the center frequency. The used value is indicated in the "Value" field.
"= Marker" | This setting is only available if a marker is active. Sets the step size to the value of the current marker and removes the coupling of the step size to span. The used value is indicated in the "Value" field.
"Manual" | Defines a fixed step size for the center frequency. Enter the step size in the "Value" field.
Remote command:

[SENSe:​]FREQuency:​CENTer:​STEP


Frequency Offset

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Frequency Settings > Frequency Offset
Frequency Offset

Shifts the displayed frequency range along the x-axis by the defined offset.

This parameter has no effect on the R&S FSW hardware, or on the captured data or on data processing. It is simply a manipulation of the final results in which absolute frequency values are displayed. Thus, the x-axis of a spectrum display is shifted by a constant offset if it shows absolute frequencies, but not if it shows frequencies relative to the signal's center frequency.

A frequency offset can be used to correct the display of a signal that is slightly distorted by the measurement setup, for example.

The allowed values range from -100 GHz to 100 GHz. The default setting is 0 Hz.

Remote command:

[SENSe:​]FREQuency:​OFFSet


Trigger Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings
Trigger Settings

Trigger settings determine when the input signal is measured.

External triggers from one of the TRIGGER INPUT/OUTPUT connectors on the R&S FSW are configured in a separate tab of the dialog box.

For step-by-step instructions on configuring triggered measurements, see "How to Configure a Triggered and Gated Measurement" .

For step-by-step instructions on configuring triggered measurements, see the main R&S FSW User Manual.

└ Trigger Source
└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ IF Power
└ RF Power
└ I/Q Power
└ Trigger Level
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Trigger Source

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source
Trigger Source

The trigger settings define the beginning of a measurement.

└ Trigger Source
└ Free Run
└ External Trigger 1/2/3
└ IF Power
└ RF Power
└ I/Q Power
└ Trigger Level
└ Drop-Out Time
└ Trigger Offset
└ Hysteresis
└ Trigger Holdoff
└ Slope


Trigger Source

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Trigger Source
Trigger Source

Defines the trigger source. If a trigger source other than "Free Run" is set, "TRG" is displayed in the channel bar and the trigger source is indicated.

Remote command:

TRIGger[:​SEQuence]:​SOURce

└ Free Run
└ External Trigger 1/2/3
└ IF Power
└ RF Power
└ I/Q Power


Free Run

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Trigger Source > Free Run
Free Run

No trigger source is considered. Data acquisition is started manually or automatically and continues until stopped explicitely.

Remote command:

TRIG:SOUR IMM, see TRIGger[:​SEQuence]:​SOURce


External Trigger 1/2/3

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Trigger Source > External Trigger 1/2/3
External Trigger 1/2/3

Data acquisition starts when the TTL signal fed into the specified input connector (on the front or rear panel) meets or exceeds the specified trigger level.

(See "Trigger Level (Repetition interval)" ).

Note: The "External Trigger 1" softkey automatically selects the trigger signal from the TRIGGER INPUT connector on the front panel.

For details see "TRIGGER INPUT / OUTPUT" and "TRIGGER 3 INPUT/ OUTPUT" .

"External Trigger 1" | Trigger signal from the TRIGGER 1 INPUT connector on the front panel.
"External Trigger 2" | Trigger signal from the TRIGGER 2 INPUT/OUTPUT connector on the front panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
"External Trigger 3" | Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector on the rear panel. Note: Connector must be configured for "Input" in the "Outputs" configuration (see "Trigger 2/3").
Remote command:

TRIG:SOUR EXT, TRIG:SOUR EXT2

TRIG:SOUR EXT3

See TRIGger[:​SEQuence]:​SOURce


IF Power

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Trigger Source > IF Power
IF Power

The R&S FSW starts capturing data as soon as the trigger level is exceeded around the third intermediate frequency.

This trigger source is only available for RF input.

For frequency sweeps, the third IF represents the start frequency. The trigger bandwidth at the third IF depends on the RBW and sweep type.

For measurements on a fixed frequency (e.g. zero span or I/Q measurements), the third IF represents the center frequency.

The available trigger levels depend on the RF attenuation and preamplification. A reference level offset, if defined, is also considered.

For details on available trigger levels and trigger bandwidths see the data sheet.

Note: Be aware that in auto sweep type mode, due to a possible change in sweep types, the trigger bandwidth may vary considerably for the same RBW setting.

Remote command:

TRIG:SOUR IFP, see TRIGger[:​SEQuence]:​SOURce


RF Power

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Trigger Source > RF Power
RF Power

Defines triggering of the measurement via signals which are outside the displayed measurement range.

For this purpose the instrument uses a level detector at the first intermediate frequency. The input signal must be in the frequency range between 500 MHz and 8 GHz.

The resulting trigger level at the RF input depends on the RF attenuation and preamplification. For details on available trigger levels see the data sheet.

Note: If the input signal contains frequencies outside of this range (e.g. for fullspan measurements), the sweep may be aborted and a message indicating the allowed input frequencies is displayed in the status bar.

A "Trigger Offset", "Trigger Polarity" and "Trigger Holdoff" (to improve the trigger stability) can be defined for the RF trigger, but no "Hysteresis".

Remote command:

TRIG:SOUR RFP, see TRIGger[:​SEQuence]:​SOURce


I/Q Power

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Trigger Source > I/Q Power
I/Q Power

This trigger source is not available if the optional Digital Baseband Interface (R&S FSW-B17) or Analog Baseband Interface (R&S FSW-B71) is used for input. It is also not available for analysis bandwidths ≥ 160 MHz.

Triggers the measurement when the magnitude of the sampled I/Q data exceeds the trigger threshold.

Remote command:

TRIG:SOUR IQP, see TRIGger[:​SEQuence]:​SOURce


Trigger Level

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Trigger Level
Trigger Level

Defines the trigger level for the specified trigger source.

For details on supported trigger levels, see the data sheet.

Remote command:

TRIGger[:​SEQuence]:​LEVel:​IFPower

TRIGger[:​SEQuence]:​LEVel:​IQPower

TRIGger[:​SEQuence]:​LEVel[:​EXTernal<port>]


Drop-Out Time

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Drop-Out Time
Drop-Out Time

Defines the time the input signal must stay below the trigger level before triggering again.

For more information on the drop-out time see "Trigger Drop-Out Time" .

Remote command:

TRIGger[:​SEQuence]:​DTIMe


Trigger Offset

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Trigger Offset
Trigger Offset

Defines the time offset between the trigger event and the start of the sweep.

offset > 0: | Start of the sweep is delayed
offset < 0: | Sweep starts earlier (pre-trigger)
Remote command:

TRIGger[:​SEQuence]:​HOLDoff[:​TIME]


Hysteresis

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Hysteresis
Hysteresis

Defines the distance in dB to the trigger level that the trigger source must exceed before a trigger event occurs. Settting a hysteresis avoids unwanted trigger events caused by noise oscillation around the trigger level.

This setting is only available for "IF Power" trigger sources. The range of the value is between 3 dB and 50 dB with a step width of 1 dB.

For more information see "Trigger Hysteresis" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HYSTeresis


Trigger Holdoff

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Trigger Holdoff
Trigger Holdoff

Defines the minimum time (in seconds) that must pass between two trigger events. Trigger events that occur during the holdoff time are ignored.

For more information see "Trigger Holdoff" .

Remote command:

TRIGger[:​SEQuence]:​IFPower:​HOLDoff


Slope

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger Source > Slope
Slope

For all trigger sources except time and frequency mask (Realtime only) you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Remote command:

TRIGger[:​SEQuence]:​SLOPe


Trigger 2/3

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger 2/3
Trigger 2/3

Defines the usage of the variable TRIGGER INPUT/OUTPUT connectors, where:

"Trigger 2": TRIGGER INPUT/OUTPUT connector on the front panel

"Trigger 3": TRIGGER 3 INPUT/ OUTPUT connector on the rear panel

(Trigger 1 is INPUT only.)

Note: Providing trigger signals as output is described in detail in "How to Output a Trigger Signal" .

"Input" | The signal at the connector is used as an external trigger source by the R&S FSW. No further trigger parameters are available for the connector.
"Output" | The R&S FSW sends a trigger signal to the output connector to be used by connected devices. Further trigger parameters are available for the connector.
Remote command:

OUTPut:​TRIGger<port>:​LEVel

OUTPut:​TRIGger<port>:​DIRection

└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Output Type

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger 2/3 > Output Type
Output Type

Type of signal to be sent to the output

"Device Triggered" | (Default) Sends a trigger when the R&S FSW triggers.
"Trigger Armed" | Sends a (high level) trigger when the R&S FSW is in "Ready for trigger" state. This state is indicated by a status bit in the STATus:OPERation register (bit 5), as well as by a low level signal at the AUX port (pin 9).
"User Defined" | Sends a trigger when user selects "Send Trigger" button. In this case, further parameters are available for the output signal.
Remote command:

OUTPut:​TRIGger<port>:​OTYPe

└ Level
└ Pulse Length
└ Send Trigger


Level

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger 2/3 > Output Type > Level
Level

Defines whether a constant high (1) or low (0) signal is sent to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​LEVel


Pulse Length

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger 2/3 > Output Type > Pulse Length
Pulse Length

Defines the length of the pulse sent as a trigger to the output connector.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​LENGth


Send Trigger

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Trigger Settings > Trigger 2/3 > Output Type > Send Trigger
Send Trigger

Sends a user-defined trigger to the output connector immediately. Note that the trigger pulse level is always opposite to the constant signal level defined by the output "Level" setting, e.g. for "Level = High", a constant high signal is output to the connector until the "Send Trigger" button is selected. Then, a low pulse is sent.

Which pulse level will be sent is indicated by a graphic on the button.

Remote command:

OUTPut:​TRIGger<port>:​PULSe:​IMMediate


Multi-Carrier Configuration

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration
Multi-Carrier Configuration

The multiple carriers are configured in the "Multi-Carrier Config" dialog box.

To display this dialog box, do one of the following:

  • Select the "Multi-Carrier Config" button in the "Overview".
  • Select the MEAS CONFIG key and then the "Multi-Carrier Config" softkey.
Contents
  • Measurement Configuration
  • Calibration


Measurement Configuration

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Measurement Configuration
Measurement Configuration

The measurement parameters for group delay calculation are configured in the "Meas Config" tab of the "Multi-Carrier Config" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Multi-Carrier Config" button in the "Overview" and switch to the "Multi-Carrier Config" tab.
  • Select the MEAS CONFIG key and then the "Multi-Carrier Config" softkey.
└ Center frequency
└ Carrier Spacing
└ Number of Carriers
└ Span
└ Measurement Time
└ Sweep Count
└ Group Delay Mode
└ Carrier Estimation
└ Estimation Type


Carrier Spacing

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Measurement Configuration > Carrier Spacing
Carrier Spacing

Defines the spacing between two carriers. The "Span" and the "Number of Carriers" are adapted accordingly (see "Dependancy of the span on the number of carriers").

Remote command:

[SENSe:​]CARRier:​SPACing


Number of Carriers

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Measurement Configuration > Number of Carriers
Number of Carriers

Defines the number of carriers in the signal. The "Span" and "Carrier Spacing" are adapted according to the following formula:

Number of carriers -1 = Span / Carrier spacing

Note: When loading calibration data, the number of carriers in the stored data must correspond to the currently defined number of carriers for the measurement, otherwise loading fails.

For details see "Dependancy of the span on the number of carriers".

Remote command:

[SENSe:​]CARRier:​COUNt


Span

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Measurement Configuration > Span
Span

Defines the frequency span to be measured. Only a multiple of the carrier spacing can be defined. The "Number of Carriers" is adapted accordingly (see "Dependancy of the span on the number of carriers").

Remote command:

[SENSe:​]FREQuency:​SPAN


Measurement Time

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Measurement Configuration > Measurement Time
Measurement Time

Defines the duration of the measurement

"Auto" | (Default:) In automatic mode the required time is determined according to carrier spacing and span; the currently used measurement time is indicated for reference only
"Manual" | The measurement time is defined manually; enter the measurement time in seconds
Remote command:

[SENSe:​]MTIMe?

[SENSe:​]MTIMe:​AUTO


Sweep Count

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Measurement Configuration > Sweep Count
Sweep Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 32767 are allowed. If the values 0 or 1 are set, one sweep is performed. The sweep count is applied to all the traces in all diagrams.

During calibration measurements, the phase and amplitude values are averaged over the defined number of sweeps.

If the trace configurations "Average", "Max Hold" or "Min Hold" are set, this value also determines the number of averaging or maximum search procedures.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

Remote command:

[SENSe:​]SWEep:​COUNt


Group Delay Mode

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Measurement Configuration > Group Delay Mode
Group Delay Mode

Defines how the group delay is calculated.

"Absolute" | Calculates the absolute group delay; requires an external trigger
"Relative" | Calculates the relative group delay; constant delay parts are compensated for
Remote command:

CALCulate:​GRPDelay:​MODE


Carrier Estimation

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Measurement Configuration > Carrier Estimation
Carrier Estimation

Defines whether the carrier frequencies are estimated and then compensated for.

"On" | The carrier frequencies are estimated and then compensated for during calculation. Which method is used to estimate the frequencies is defined by the "Estimation Type".
"Off" | The carrier frequencies as defined in the configuration are used; possible offsets are not compensated.
Remote command:

[SENSe:​]CARRier:​OFFSet?

[SENSe:​]CARRier:​OFFSet:​MODE


Estimation Type

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Measurement Configuration > Estimation Type
Estimation Type

Defines the method used to estimate the carrier frequency if "Carrier Estimation" is enabled.

"All Carriers"

Estimates the frequency for each carrier and uses the determined frequencies when calculating the group delay.

This estimation is useful for in-orbit measurements of satellites for which the group delay may be distorted due to the Doppler effect.

"Offset"

The offset is assumed to be identical for all carriers. It is estimated and the determined frequencies are then used for calculation.

Remote command:

[SENSe:​]CARRier:​OFFSet:​MODE


Calibration

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Calibration
Calibration

Calibration is performed in the "Calibration" tab of the "Multi-Carrier Config" dialog box.

►

To display this dialog box, do one of the following:

  • Select the "Multi-Carrier Config" button in the "Overview" and switch to the "Calibration" tab.
  • Select the MEAS CONFIG key and then the "Calibrate" softkey.

The values defined by the most recently performed or loaded calibration measurement are displayed at the top of the dialog box.

└ Calibrate (Execute Reference Calibration)
└ Storing Calibration Data
└ Loading Calibration Data
└ Decimal Separator


Calibrate (Execute Reference Calibration)

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Calibration > Calibrate (Execute Reference Calibration)
Calibrate (Execute Reference Calibration)

Starts a new sweep to perform a calibration measurement. The status of the running measurement is indicated in a dialog box. During this time, no other actions can be performed on the R&S FSW. The results are used as reference data for the group delay calculation.

The date and time of the most recently performed or loaded calibration measurement is indicated in the channel bar and at the top of the dialog box.

Remote command:

CALibration:​MCGD


Storing Calibration Data

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Calibration > Storing Calibration Data
Storing Calibration Data

Stores the calibration data (reference data) to the selected file (.csv format)

Remote command:

MMEMory:​STORe:​MCGD:​RCALibration


Loading Calibration Data

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Calibration > Loading Calibration Data
Loading Calibration Data

Loads the calibration data (reference data) from the selected file (.csv format) to the instrument. The current reference data in the MCGD application is overwritten; the loaded data is used for the group delay calculation.

Note: When loading calibration data, the number of carriers in the stored data must correspond to the currently defined number of carriers for the measurement, otherwise loading fails.

Remote command:

MMEMory:​LOAD:​MCGD:​RCALibration


Decimal Separator

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Multi-Carrier Configuration > Calibration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Sweep Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Sweep Settings
Sweep Settings

The sweep settings define how often data from the input signal is acquired and then evaluated. They are configured via the SWEEP key.

The "Sweep" menu also contains some softkeys for MCGD configuration settings, see "Multi-Carrier Configuration".

└ Continuous Sweep/RUN CONT
└ Single Sweep/ RUN SINGLE
└ Continue Single Sweep
└ Calibrate (Execute Reference Calibration)
└ Measurement Time
└ Sweep Count


Continuous Sweep/RUN CONT

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Sweep Settings > Continuous Sweep/RUN CONT
Continuous Sweep/RUN CONT

While the measurement is running, the "Continuous Sweep" softkey and the RUN CONT key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again. The results are not deleted until a new measurement is started.

Note: Sequencer. Furthermore, the RUN CONT key controls the Sequencer, not individual sweeps. RUN CONT starts the Sequencer in continuous mode.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate:​CONTinuous


Single Sweep/ RUN SINGLE

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Sweep Settings > Single Sweep/ RUN SINGLE
Single Sweep/ RUN SINGLE

While the measurement is running, the "Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Note: Sequencer. Furthermore, the RUN SINGLE key controls the Sequencer, not individual sweeps. RUN SINGLE starts the Sequencer in single mode.
If the Sequencer is off, only the evaluation for the currently displayed measurement channel is updated.
For details on the Sequencer, see "The Sequencer Concept" .

Remote command:

INITiate[:​IMMediate]


Continue Single Sweep

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Sweep Settings > Continue Single Sweep
Continue Single Sweep

While the measurement is running, the "Continue Single Sweep" softkey and the RUN SINGLE key are highlighted. The running measurement can be aborted by selecting the highlighted softkey or key again.

Remote command:

INITiate:​CONMeas


Calibrate (Execute Reference Calibration)

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Sweep Settings > Calibrate (Execute Reference Calibration)
Calibrate (Execute Reference Calibration)

Starts a new sweep to perform a calibration measurement. The status of the running measurement is indicated in a dialog box. During this time, no other actions can be performed on the R&S FSW. The results are used as reference data for the group delay calculation.

The date and time of the most recently performed or loaded calibration measurement is indicated in the channel bar and at the top of the dialog box.

Remote command:

CALibration:​MCGD


Measurement Time

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Sweep Settings > Measurement Time
Measurement Time

Defines the duration of the measurement

"Auto" | (Default:) In automatic mode the required time is determined according to carrier spacing and span; the currently used measurement time is indicated for reference only
"Manual" | The measurement time is defined manually; enter the measurement time in seconds
Remote command:

[SENSe:​]MTIMe?

[SENSe:​]MTIMe:​AUTO


Sweep Count

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Sweep Settings > Sweep Count
Sweep Count

Defines the number of sweeps to be performed in the single sweep mode. Values from 0 to 32767 are allowed. If the values 0 or 1 are set, one sweep is performed. The sweep count is applied to all the traces in all diagrams.

During calibration measurements, the phase and amplitude values are averaged over the defined number of sweeps.

If the trace configurations "Average", "Max Hold" or "Min Hold" are set, this value also determines the number of averaging or maximum search procedures.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

Remote command:

[SENSe:​]SWEep:​COUNt


Output Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Output Settings
Output Settings

The R&S FSW can provide output to special connectors for other devices.

For details on connectors refer to "Instrument Tour" .

Providing trigger signals as output is described in "How to Output a Trigger Signal" .

Output settings can be configured via the INPUT/OUTPUT key or in the "Outputs" dialog box.

└ Noise Source
└ Trigger 2/3
└ Output Type
└ Level
└ Pulse Length
└ Send Trigger


Noise Source

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Output Settings > Noise Source
Noise Source

Switches the supply voltage for an external noise source on or off.

External noise sources are useful when you are measuring power levels that fall below the noise floor of the R&S FSW itself, for example when measuring the noise level of a DUT.

Remote command:

DIAGnostic:​SERVice:​NSOurce


Automatic Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Automatic Settings
Automatic Settings

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings and signal characteristics.

MSRA operating mode

In MSRA operating mode, the following automatic settings are not available, as they require a new data acquisition. However, the GSM application cannot perform data acquisition in MSRA operating mode.

To activate the automatic adjustment of a setting, select the corresponding function in the AUTO SET menu.

└ Setting the Reference Level Automatically (Auto Level)
└ Resetting the Automatic Measurement Time (Meastime Auto)
└ Changing the Automatic Measurement Time (Meastime Manual)
└ Upper Level Hysteresis
└ Lower Level Hysteresis


Setting the Reference Level Automatically (Auto Level)

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Automatic Settings > Setting the Reference Level Automatically (Auto Level)
Setting the Reference Level Automatically (Auto Level)

Automatically determines the optimal reference level for the current input data. At the same time, the internal attenuators and the preamplifier (for analog baseband input: the full scale level) are adjusted so the signal-to-noise ratio is optimized, while signal compression, clipping and overload conditions are minimized.

In order to do so, a level measurement is performed to determine the optimal reference level.

You can change the measurement time for the level measurement if necessary (see "Changing the Automatic Measurement Time (Meastime Manual)").

Remote command:

[SENSe:​]ADJust:​LEVel


Resetting the Automatic Measurement Time (Meastime Auto)

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Automatic Settings > Resetting the Automatic Measurement Time (Meastime Auto)
Resetting the Automatic Measurement Time (Meastime Auto)

Resets the measurement duration for automatic settings to the default value.

For details see "Adjusting Settings Automatically" .

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE


Changing the Automatic Measurement Time (Meastime Manual)

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Automatic Settings > Changing the Automatic Measurement Time (Meastime Manual)
Changing the Automatic Measurement Time (Meastime Manual)

This function allows you to change the measurement duration for automatic setting adjustments. Enter the value in seconds.

For details see "Adjusting Settings Automatically" .

Remote command:

[SENSe:​]ADJust:​CONFigure:​DURation:​MODE

[SENSe:​]ADJust:​CONFigure:​DURation


Upper Level Hysteresis

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Automatic Settings > Upper Level Hysteresis
Upper Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​UPPer


Lower Level Hysteresis

Multi-Carrier Group Delay (R&S FSW-K17) > Configuration > Automatic Settings > Lower Level Hysteresis
Lower Level Hysteresis

When the reference level is adjusted automatically using the Auto Level function, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Remote command:

[SENSe:​]ADJust:​CONFigure:​HYSTeresis:​LOWer


Analysis

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis
Analysis

General result analysis settings concerning the trace, markers, windows etc. can be configured via the "Analysis" button in the "Overview". They are identical to the analysis functions in the base unit except for the special window functions.

Contents
  • Trace Settings
  • Trace / Data Export Configuration
  • Markers
  • Display Configuration
  • Zoom Functions


Trace Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace Settings
Trace Settings

The trace settings determine how the measured data is analyzed and displayed in the window. Depending on the result display, between 1 and 4 traces may be displayed.

Trace settings can be configured via the TRACE key, in the "Traces" dialog box, or in the vertical "Traces" tab of the "Analysis" dialog box.

Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box (see "Specifics for").

Trace data can also be exported to an ASCII file for further analysis. For details see "Trace / Data Export Configuration".

└ Trace 1/Trace 2/Trace 3/Trace 4
└ Mode
└ Hold
└ Smoothing (Group Delay only)
└ Average Mode
└ Average Count
└ Predefined Trace Settings - Quick Config
└ Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)


Trace 1/Trace 2/Trace 3/Trace 4

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4
Trace 1/Trace 2/Trace 3/Trace 4

Selects the corresponding trace for configuration. The currently selected trace is highlighted orange.

For details see "How to Configure a Standard Trace" .

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]

Selected via numeric suffix of TRACe<t> commands


Mode

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace Settings > Mode
Mode

Defines the update mode for subsequent traces.

For details see "Analyzing Several Traces - Trace Mode" .

"Clear Write" | Overwrite mode: the trace is overwritten by each sweep. This is the default setting.
"Max Hold" | The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.
"Min Hold" | The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.
"Average" | The average is formed over several sweeps. The "Average Count" determines the number of averaging procedures.
"View" | The current contents of the trace memory are frozen and displayed.
"Blank" | Removes the selected trace from the display.
Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE


Hold

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace Settings > Hold
Hold

If activated, traces in "Min Hold", "Max Hold" and "Average" mode are not reset after specific parameter changes have been made.

Normally, the measurement is started anew after parameter changes, before the measurement results are analyzed (e.g. using a marker). In all cases that require a new measurement after parameter changes, the trace is reset automatically to avoid false results (e.g. with span changes). For applications that require no reset after parameter changes, the automatic reset can be switched off.

The default setting is off.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE:​HCONtinuous


Smoothing (Group Delay only)

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace Settings > Smoothing (Group Delay only)
Smoothing (Group Delay only)

If enabled, the Group Delay trace is smoothed by the specified value (between 1 % and 50 %). The smoothing value is defined as a percentage of the display width. The larger the smoothing value, the greater the smoothing effect.

This setting is only available for Group Delay results.

For more information see "Trace Smoothing".

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>:​SMOothing[:​STATe]

DISPlay[:​WINDow<n>]:​TRACe<t>:​SMOothing:​APERture


Average Mode

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace Settings > Average Mode
Average Mode

Defines the mode with which the trace is averaged over several sweeps. A different averaging mode can be defined for each trace.

This setting is only applicable if trace mode "Average" is selected.

How many sweeps are averaged is defined by the "Average Count".

For details see "How Trace Data is Averaged - the Averaging Mode" .

"Linear" | The power level values are converted into linear units prior to averaging. After the averaging, the data is converted back into its original unit.
"Logarithmic" | For logarithmic scaling, the values are averaged in dBm. For linear scaling, the behavior is the same as with linear averaging.
"Power" | Activates linear power averaging. The power level values are converted into unit Watt prior to averaging. After the averaging, the data is converted back into its original unit. Use this mode to average power values in Volts or Amperes correctly.
Remote command:

[SENSe:​]AVERage<n>:​TYPE


Average Count

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace Settings > Average Count
Average Count

Determines the number of averaging or maximum search procedures If the trace modes "Average", "Max Hold" or "Min Hold" are set.

In continuous sweep mode, if sweep count = 0 (default), averaging is performed over 10 sweeps. For sweep count =1, no averaging, maxhold or minhold operations are performed.

This value is identical to the "Sweep Count" setting in the "Sweep" and "Multi-carrier" configuration.

Remote command:

[SENSe:​]AVERage:​COUNt


Predefined Trace Settings - Quick Config

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace Settings > Predefined Trace Settings - Quick Config
Predefined Trace Settings - Quick Config

Commonly required trace settings have been predefined and can be applied very quickly by selecting the appropriate button.

Function | Trace Settings
Preset All Traces | Trace 1: | Clear Write
 | Traces 2-4: | Blank
Set Trace Mode Max | Avg | Min | Trace 1: | Max Hold
 | Trace 2: | Average
 | Trace 3: | Min Hold
 | Trace 4: | Blank
Set Trace Mode Max | ClrWrite | Min | Trace 1: | Max Hold
 | Trace 2: | Clear Write
 | Trace 3: | Min Hold
 | Trace 4: | Blank


Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace Settings > Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)
Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)

Displays the "Traces" settings and focuses the "Mode" list for the selected trace.

Remote command:

DISPlay[:​WINDow<n>]:​TRACe<t>[:​STATe]


Trace / Data Export Configuration

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace / Data Export Configuration
Trace / Data Export Configuration

The R&S FSW provides various evaluation methods for the results of the performed measurements. However, you may want to evaluate the data with other, external applications. In this case, you can export the measurement data to a standard format file (ASCII or CSV).

The standard data management functions (e.g. saving or loading instrument settings) that are available for all R&S FSW applications are not described here.

See "Data Management" for a description of the standard functions.

For step-by-step instructions on how to export a trace, see "How to Export Trace Data" .

└ Export all Traces and all Table Results
└ Include Instrument Measurement Settings
└ Trace to Export
└ Decimal Separator
└ Export Trace to ASCII File


Export all Traces and all Table Results

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace / Data Export Configuration > Export all Traces and all Table Results
Export all Traces and all Table Results

Selects all displayed traces and result tables (e.g. Result Summary, marker table etc.) in the current application for export to an ASCII file.

Alternatively, you can select one specific trace only for export (see "Trace to Export").

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Remote command:

FORMat:​DEXPort:​TRACes


Include Instrument Measurement Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace / Data Export Configuration > Include Instrument Measurement Settings
Include Instrument Measurement Settings

Includes additional instrument and measurement settings in the header of the export file for result data.

See "Reference: ASCII File Export Format" for details.

Remote command:

FORMat:​DEXPort:​HEADer


Trace to Export

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace / Data Export Configuration > Trace to Export
Trace to Export

Defines an individual trace that will be exported to a file.

This setting is not available if "Export all Traces and all Table Results" is selected.


Decimal Separator

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace / Data Export Configuration > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Export Trace to ASCII File

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Trace / Data Export Configuration > Export Trace to ASCII File
Export Trace to ASCII File

Opens a file selection dialog box and saves the selected trace in ASCII format (.dat) to the specified file and directory.

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Both measurement and reference (calibration) traces can be exported to an ASCII file. However, the calibration data stored in an ASCII file cannot be re-imported to the R&S FSW (to re-import the data use "Storing Calibration Data" instead).

Note: To store the measurement results for all traces in all windows in .csv format, use the "Storing Measurement Results" command in the "Save/Recall" > "Export" menu.
For details on the file formats see "Annex".

Note: Secure user mode.

In secure user mode, settings that are to be stored on the instrument are stored to volatile memory, which is restricted to 256 MB. Thus, a "Memory full" error may occur although the hard disk indicates that storage space is still available.

To store data permanently, select an external storage location such as a USB memory device.

For details see "Protecting Data Using the Secure User Mode" .

Remote command:

MMEMory:​STORe:​TRACe


Markers

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers
Markers

Markers help you analyze your measurement results by determining particular values in the diagram. Thus you can extract numeric values from a graphical display.

Markers are configured in the "Marker" dialog box which is displayed when you do one of the following:

  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.
  • Press the MKR key, then select the "Marker Config" softkey.
Window-specific configuration

The settings in this dialog box are specific to the selected window. To configure the settings for a different window, select the window outside the displayed dialog box, or select the window from the "Specifics for" selection list in the dialog box.

Contents
  • Marker Settings
  • Marker Search Settings and Positioning Functions


Marker Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings
Marker Settings

Marker settings can be configured via the MARKER key or in the "Marker" dialog box. To display the "Marker" dialog box, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab.

The remote commands required to define these settings are described in "General Marker Settings".

Contents
  • Individual Marker Setup
  • General Marker Settings


Individual Marker Setup

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup
Individual Marker Setup

In the Mutli-Carrier Group Delay application, up to 17 markers or delta markers can be activated for each window simultaneously. Initial marker setup is performed using the "Marker" dialog box.

The markers are distributed among 3 tabs for a better overview. By default, the first marker is defined as a normal marker, whereas all others are defined as delta markers with reference to the first marker. All markers are assigned to trace 1, but only the first marker is active.

└ Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
└ Select Marker
└ Selected Marker
└ Marker State
└ Marker Position (X-value)
└ Marker Type
└ Reference Marker
└ Linking to Another Marker
└ Assigning the Marker to a Trace
└ All Markers Off


Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta
Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta

The "Marker X" softkey activates the corresponding marker and opens an edit dialog box to enter the marker position ("X-value"). Pressing the softkey again deactivates the selected marker.

Marker 1 is always the default reference marker for relative measurements. If activated, markers 2 to 16 are delta markers that refer to marker 1. These markers can be converted into markers with absolute value display using the "Marker Type" function.

Several markers can be configured very easily using the "Marker" dialog box, see "Marker Settings" .

Note: If normal marker 1 is the active marker, pressing the "Mkr Type" softkey switches on an additional delta marker 1.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​MARKer<m>:​Y?

CALCulate<n>:​DELTamarker<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>:​X

CALCulate<n>:​DELTamarker<m>:​X:​RELative?

CALCulate<n>:​DELTamarker<m>:​Y?


Select Marker

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > Select Marker
Select Marker

Opens a dialog box to select and activate or deactivate one or more markers quickly.

Remote command:

Marker selected via suffix <m> in remote commands.


Selected Marker

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > Selected Marker
Selected Marker

Marker name. The marker which is currently selected for editing is highlighted orange.

Remote command:

Marker selected via suffix <m> in remote commands.


Marker State

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > Marker State
Marker State

Activates or deactivates the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Marker Position (X-value)

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > Marker Position (X-value)
Marker Position (X-value)

Defines the position (x-value) of the marker in the diagram.

Remote command:

CALCulate<n>:​MARKer<m>:​X

CALCulate<n>:​DELTamarker<m>:​X


Marker Type

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > Marker Type
Marker Type

Toggles the marker type.

The type for marker 1 is always "Normal", the type for delta marker 1 is always "Delta". These types cannot be changed.

Note: If normal marker 1 is the active marker, switching the "Mkr Type" activates an additional delta marker 1. For any other marker, switching the marker type does not activate an additional marker, it only switches the type of the selected marker.

"Normal" | A normal marker indicates the absolute value at the defined position in the diagram.
"Delta" | A delta marker defines the value of the marker relative to the specified reference marker (marker 1 by default).
Remote command:

CALCulate<n>:​MARKer<m>[:​STATe]

CALCulate<n>:​DELTamarker<m>[:​STATe]


Reference Marker

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > Reference Marker
Reference Marker

Defines a marker as the reference marker which is used to determine relative analysis results (delta marker values).

Remote command:

CALCulate<n>:​DELTamarker<m>:​MREF


Linking to Another Marker

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > Linking to Another Marker
Linking to Another Marker

Links the current marker to the marker selected from the list of active markers. If the x-axis value of the inital marker is changed, the linked marker follows on the same x-position. Linking is off by default.

Using this function you can set two markers on different traces to measure the difference (e.g. between a max hold trace and a min hold trace or between a measurement and a reference trace).

Remote command:

CALCulate<n>:​MARKer<m1>:​LINK:​TO:​MARKer<m2>

CALCulate<n>:​DELTamarker<m1>:​LINK:​TO:​MARKer<m2>

CALCulate<n>:​DELTamarker<m>:​LINK


Assigning the Marker to a Trace

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > Assigning the Marker to a Trace
Assigning the Marker to a Trace

The "Trace" setting assigns the selected marker to an active trace. The trace determines which value the marker shows at the marker position. If the marker was previously assigned to a different trace, the marker remains on the previous frequency or time, but indicates the value of the new trace.

If a trace is turned off, the assigned markers and marker functions are also deactivated.

Remote command:

CALCulate<n>:​MARKer<m>:​TRACe


All Markers Off

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > Individual Marker Setup > All Markers Off
All Markers Off

Deactivates all markers in one step.

Remote command:

CALCulate<n>:​MARKer<m>:​AOFF


General Marker Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > General Marker Settings
General Marker Settings

Some general marker settings allow you to influence the marker behavior for all markers.

These settings are located in the "Marker Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker" tab. Then select the horizontal "Marker Settings" tab.
└ Marker Table Display
└ Linked Markers


Marker Table Display

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > General Marker Settings > Marker Table Display
Marker Table Display

Defines how the marker information is displayed.

For more details see "Marker Results" .

"On" | Displays the marker information in a table in a separate area beneath the diagram.
"Off" | Displays the marker information within the diagram area.
"Auto" | (Default) Up to two markers are displayed in the diagram area. If more markers are active, the marker table is displayed automatically.
Remote command:

DISPlay:​MTABle


Linked Markers

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Settings > General Marker Settings > Linked Markers
Linked Markers

If enabled, the markers in all diagrams are linked, i.e. when you move a marker in one window, the markers in all other windows are moved to the same x-value.

Linking markers is only possible if compatible reference data is available, or no reference data at all. Compatible reference data means the settings used to perform calibration were the same as the currently active measurement settings. If measurement settings are changed that do not match the reference data, linking markers is no longer possible and the function is automatically deactivated.

An exception to this rule is the center frequency. If a different center frequency was used for calibration, the markers can still be linked. However, in this case the markers are not moved to a specific x-value, but to the same horizontal position relative to the diagram edge.

Remote command:

CALCulate<n>:​MARKer<m>:​LINK


Marker Search Settings and Positioning Functions

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Search Settings and Positioning Functions
Marker Search Settings and Positioning Functions

Several functions are available to set the marker to a specific position very quickly and easily, or to use the current marker position to define another characteristic value. In order to determine the required marker position, searches may be performed. The search results can be influenced by special settings.

The remote commands required to define these settings are described in "Searching for Peaks and Positioning the Marker".

Contents
  • Marker Search Settings
  • Positioning Functions


Marker Search Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Search Settings and Positioning Functions > Marker Search Settings
Marker Search Settings

Markers are commonly used to determine peak values, i.e. maximum or minimum values, in the measured signal. Configuration settings allow you to influence the peak search results.

These settings are available as softkeys in the Marker To menu, or in the "Search Settings" tab of the "Marker" dialog box. To display this tab, do one of the following:

  • Press the MKR key, then select the "Marker Config" softkey. Then select the horizontal "Search Settings" tab.
  • In the "Overview", select "Analysis", and switch to the vertical "Marker Config" tab. Then select the horizontal "Search Settings" tab.
└ Search Mode for Next Peak
└ Peak Excursion


Search Mode for Next Peak

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Search Settings and Positioning Functions > Marker Search Settings > Search Mode for Next Peak
Search Mode for Next Peak

Selects the search mode for the next peak search.

"Left" | Determines the next maximum/minimum to the left of the current peak.
"Absolute" | Determines the next maximum/minimum to either side of the current peak.
"Right" | Determines the next maximum/minimum to the right of the current peak.
Remote command:

CALCulate<n>:​DELTamarker<m>:​MAXimum:​LEFT

CALCulate<n>:​MARKer<m>:​MAXimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MAXimum:​RIGHt

CALCulate<n>:​DELTamarker<m>:​MINimum:​LEFT

CALCulate<n>:​MARKer<m>:​MINimum:​LEFT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​RIGHt

CALCulate<n>:​MARKer<m>:​MINimum:​RIGHt


Peak Excursion

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Search Settings and Positioning Functions > Marker Search Settings > Peak Excursion
Peak Excursion

Defines the minimum level value by which a signal must rise or fall so that it will be identified as a maximum or a minimum by the search functions.

For more information see "Searching for Signal Peaks" .

Remote command:

CALCulate<n>:​MARKer:​PEXCursion


Positioning Functions

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Search Settings and Positioning Functions > Positioning Functions
Positioning Functions

The following functions set the currently selected marker to the result of a peak search or set other characteristic values to the current marker value. These functions are available as softkeys in the "Marker To" menu, which is displayed when you press the MKR -> key, or in the "Marker" menu.

└ Select Marker
└ Peak Search
└ Search Next Peak
└ Search Minimum
└ Search Next Minimum


Peak Search

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Search Settings and Positioning Functions > Positioning Functions > Peak Search
Peak Search

Sets the selected marker/delta marker to the maximum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MAXimum[:​PEAK]


Search Next Peak

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Peak
Search Next Peak

Sets the selected marker/delta marker to the next (lower) maximum of the assigned trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MAXimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MAXimum:​NEXT


Search Minimum

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Search Settings and Positioning Functions > Positioning Functions > Search Minimum
Search Minimum

Sets the selected marker/delta marker to the minimum of the trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum[:​PEAK]

CALCulate<n>:​DELTamarker<m>:​MINimum[:​PEAK]


Search Next Minimum

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Markers > Marker Search Settings and Positioning Functions > Positioning Functions > Search Next Minimum
Search Next Minimum

Sets the selected marker/delta marker to the next (higher) minimum of the selected trace. If no marker is active, marker 1 is activated.

Remote command:

CALCulate<n>:​MARKer<m>:​MINimum:​NEXT

CALCulate<n>:​DELTamarker<m>:​MINimum:​NEXT


Display Configuration

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Display Configuration
Display Configuration

The captured signal can be displayed using various evaluation methods. All evaluation methods available for the Multi-Carrier Group Delay application are displayed in the evaluation bar in SmartGrid mode when you do one of the following:

  • Select the [image] "SmartGrid" icon from the toolbar.
  • Select the "Display Config" button in the "Overview".
  • Press the MEAS key.
  • Select the "Display Config" softkey in any Multi-Carrier Group Delay menu.

Up to 6 evaluation methods can be displayed simultaneously in separate windows. The Multi-Carrier Group Delay evaluation methods are described in "Evaluation Methods for Multi-Carrier Group Delay".

For details on working with the SmartGrid see "Laying out the Result Display with the SmartGrid" .


Zoom Functions

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Zoom Functions
Zoom Functions

The zoom functions are only available from the toolbar.

For details on the zoom functions see "Single Zoom Versus Multiple Zoom" .

└ Single Zoom
└ Multiple Zoom
└ Restore Original Display
└ Deactivating Zoom (Selection mode)


Single Zoom

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Zoom Functions > Single Zoom
Single Zoom

A single zoom replaces the current diagram by a new diagram which displays an enlarged extract of the trace. This function can be used repetitively until the required details are visible.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​AREA


Multiple Zoom

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Zoom Functions > Multiple Zoom
Multiple Zoom

In multiple zoom mode, you can enlarge several different areas of the trace simultaneously. An overview window indicates the zoom areas in the original trace, while the zoomed trace areas are displayed in individual windows. The zoom area that corresponds to the individual zoom display is indicated in the lower right corner, between the scrollbars.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​AREA


Restore Original Display

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Zoom Functions > Restore Original Display
Restore Original Display

Restores the original display and closes all zoom windows.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Deactivating Zoom (Selection mode)

Multi-Carrier Group Delay (R&S FSW-K17) > Analysis > Zoom Functions > Deactivating Zoom (Selection mode)
Deactivating Zoom (Selection mode)

Deactivates zoom mode.

Tapping the screen no longer invokes a zoom, but selects an object.

For details on zooming see "Zoomed Displays" .

Remote command:

DISPlay[:​WINDow<n>]:​ZOOM:​STATe (single zoom)

DISPlay[:​WINDow<n>]:​ZOOM:​MULTiple<zoom>:​STATe (for each multiple zoom window)


Importing and Exporting Results

Multi-Carrier Group Delay (R&S FSW-K17) > Importing and Exporting Results
Importing and Exporting Results

The R&S FSW provides various evaluation methods for the results of the performed measurements. However, you may want to evaluate the data with other, external applications. In this case, you can export the measurement data to a standard format file (ASCII or CSV). The results from the calibration measurements can also be be re-imported to the R&S FSW MCGD application as reference data for further measurements.

The standard data management functions (e.g. saving or loading instrument settings) that are available for all R&S FSW applications are not described here.

See "Data Management" for a description of the standard functions.

Contents
  • Export Functions
  • Import Functions


Export Functions

Multi-Carrier Group Delay (R&S FSW-K17) > Importing and Exporting Results > Export Functions
Export Functions

The following export functions are available via softkeys in the "Save/Recall" menu which is displayed when you select the "Save" or "Open" icon in the toolbar. Some functions are also available via softkeys or dialog boxes in the corresponding menus, e.g. trace data or calibration data.

└ Storing Calibration Data
└ Storing Measurement Results
└ Export Trace to ASCII File
└ Decimal Separator


Storing Calibration Data

Multi-Carrier Group Delay (R&S FSW-K17) > Importing and Exporting Results > Export Functions > Storing Calibration Data
Storing Calibration Data

Stores the calibration data (reference data) to the selected file (.csv format)

Remote command:

MMEMory:​STORe:​MCGD:​RCALibration


Storing Measurement Results

Multi-Carrier Group Delay (R&S FSW-K17) > Importing and Exporting Results > Export Functions > Storing Measurement Results
Storing Measurement Results

Stores the currently displayed measurement results (i.e. all traces in all windows) to the selected file (.csv format).

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Note: To store the results of an individual trace or all traces in ASCII format (.dat), use the "Export Trace to ASCII File" function.

The results are output in the same order as they are displayed on the screen: window by window, trace by trace, and table row by table row.

Remote command:

MMEMory:​STORe:​MCGD:​MEAS


Decimal Separator

Multi-Carrier Group Delay (R&S FSW-K17) > Importing and Exporting Results > Export Functions > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


Import Functions

Multi-Carrier Group Delay (R&S FSW-K17) > Importing and Exporting Results > Import Functions
Import Functions

The following import functions are available via softkeys in the "Save/Recall" menu which is displayed when you select the "Save" or "Open" icon in the toolbar. Calibration data can also be imported from the "Calibration" configuration dialog box.

└ Loading Calibration Data
└ Decimal Separator


Loading Calibration Data

Multi-Carrier Group Delay (R&S FSW-K17) > Importing and Exporting Results > Import Functions > Loading Calibration Data
Loading Calibration Data

Loads the calibration data (reference data) from the selected file (.csv format) to the instrument. The current reference data in the MCGD application is overwritten; the loaded data is used for the group delay calculation.

Note: When loading calibration data, the number of carriers in the stored data must correspond to the currently defined number of carriers for the measurement, otherwise loading fails.

Remote command:

MMEMory:​LOAD:​MCGD:​RCALibration


Decimal Separator

Multi-Carrier Group Delay (R&S FSW-K17) > Importing and Exporting Results > Import Functions > Decimal Separator
Decimal Separator

Defines the decimal separator for floating-point numerals for the data export files. Evaluation programs require different separators in different languages.

Remote command:

FORMat:​DEXPort:​DSEParator


How to Perform Measurements in the Multi-Carrier Group Delay Application

Multi-Carrier Group Delay (R&S FSW-K17) > How to Perform Measurements in the Multi-Carrier Group Delay Application
How to Perform Measurements in the Multi-Carrier Group Delay Application

The following step-by-step instructions demonstrate how to perform a Multi-Carrier Group Delay measurement with the R&S FSW-K17 option. For details on the individual functions and settings see "Configuration".

Additionally, the procedure to generate the multi-carrier signal for the frequency range to be analyzed on a signal generator is described, using the R&S SMU as an example. For details on configuring the signal generator, see the R&S SMU User Manual.

To generate a multi-carrier signal for the frequency range of the DUT on an R&S SMU

  1. Preset the signal generator.

  2. In the "Baseband" menu, select "Multicarrier CW". (Alternatively, the R&S SMU can produce multi-carrier signals using the "ARB" option.)

  3. In the "Carrier Setup" area define the "No of Carriers" and "Carrier Spacing" such that the generated signal covers the frequency range in which the DUT is to be analyzed.

  4. In the "Optimize Crest Factor Mode" field, select "Chirp" to improve the SNR in the MC Group Delay measurement.

  5. To improve measurement accuracy, send a trigger signal to the R&S FSW:

    1. Select the "Trigger/Marker" button.

    2. Select MODE and select "Auto".

    3. Select MARKER 1 and select "Restart".

    4. Exit the "Trigger/Marker" menu.

  6. Activate the multi-carrier signal by switching "State" to "ON".

  7. Close the "Baseband" menu.

  8. Open the "RF/A Mod" menu.

  9. In the "RF/A Mod" menu, select "RF ON" to activate the RF modulation.

  10. Select the FREQ key to define the center frequency of the test signal.

  11. Select the LEVEL key to define the generator's output power.

To perform the MC Group Delay measurement on the R&S FSW

  1. To use the trigger from the signal generator on the R&S FSW, for example to calculate an absolute group delay, connect the trigger output of the signal generator (Marker 1 on the R&S SMU in the example above) to the trigger input of the R&S FSW.

  2. To synchronize the reference frequencies used by the signal generator and the R&S FSW, use an external reference frequency:

    1. Connect the external reference output of the signal generator (REF OUT) to the external reference input on the rear panel of the R&S FSW (REF INPUT 1..20 MHz).

    2. On the R&S FSW, press the SETUP key, then select the "Reference" softkey.

    3. In the "Reference Frequency Input" area select the used external reference.

  3. Connect the signal generator to the RF INPUT connector on the front panel of the R&S FSW without the DUT.

  4. Configure the signal generator to output a multi-carrier signal in the frequency range in which the DUT is to be analyzed (as described in "To generate a multi-carrier signal for the frequency range of the DUT on an R&S SMU").

  5. Press the MODE key on the front panel of the R&S FSW and select the "MC Group Delay" application.

  6. Select the "Overview" softkey to display the "Overview" for a Multi-Carrier Group Delay measurement.

  7. Select the "Amplitude" button and define the required attenuation and reference level for the generated input signal.

    Note: Correct attenuation and reference level settings are an important factor for accurate group delay measurement results. You can also use the auto leveling function in the R&S FSW Spectrum application before starting the MCGD application. The attenuation and reference level values are then passed on to the new MCGD measurement channel.

  8. Select the "Frequency" button to define the input signal's center frequency.

  9. To measure the absolute group delay select the "Trigger" button and select the trigger source "External Trigger1".

  10. Select the "Multi-Carrier Config" button to describe the signal and define measurement settings:

    1. Define the carrier spacing.

    2. Define the number of carriers (tones) or the frequency span according to the settings on the generator.

    3. If the measurement time determined automatically is not adequate, define it manually.

    4. To average the results over several sweeps, increase the sweep count.

    5. To calculate an absolute group delay, select "Absolute" mode for the group delay result.

    Check the displayed results to ensure the measurement configuration is adequate.

  11. Press the RUN SINGLE key to stop the continuous sweep mode.

  12. Select the "Multi-Carrier Config" softkey to re-open the "Multi-Carrier Config" dialog box and switch to the "Calibration" tab.

  13. Select the "Calibrate" button to perform a calibration measurement.

    Alternatively, if a calibration measurement has already been performed with the same measurement setup, select the "Load Calibration Data" button to load stored reference data.

    The calibration measurement is performed. The status of the running measurement is indicated in a dialog box. During this time, no other actions can be performed on the R&S FSW.

    The date and time of the most recently performed or loaded calibration measurement is indicated in the channel bar.

  14. Optionally, to store the results from the performed calibration measurement to a CSV file for later use, select the "Store Calibration Data" button.

  15. Once the reference data is available in the Multi-Carrier Group Delay application, connect the DUT between the signal generator and the R&S FSW.

  16. On the R&S FSW, select the "Display Config" button and select the displays that are of interest to you (up to 6).

    Arrange them on the display to suit your preferences, then exit the SmartGrid mode.

  17. Press the RUN SINGLE key to start a new measurement.

    The group delay is calculated and the selected results are displayed.

  18. To store the displayed results in a CSV file:

    1. Select the [image] "Save" icon in the toolbar.

    2. Select the "Export" softkey.

    3. If necessary, change the decimal separator to be used for the export file.

    4. Select the "Store Measurement Data" softkey.

    5. Define a file name and storage location for the results file.

  19. To make use of the advanced analysis functions in the displays, select the "Analysis" button in the "Overview".

    • Configure a trace to display the average over a series of sweeps (on the "Trace" tab; if necessary, increase the "Sweep Count" in the "Multi-Carrier Config" settings).
      This is recommended for absolute group delay trace results.
    • Configure markers and delta markers to determine deviations and offsets within the signal (on the "Marker" tab).

  20. Optionally, export the trace data of the demodulated signal to a file.

    1. In the "Traces" tab of the "Analysis" dialog box, switch to the "Trace Export" tab.

    2. Select "Export Trace to ASCII File".

    3. Define a file name and storage location and select "OK".


Optimizing and Troubleshooting the Measurement

Multi-Carrier Group Delay (R&S FSW-K17) > Optimizing and Troubleshooting the Measurement
Optimizing and Troubleshooting the Measurement

If the results do not meet your expectations, try the following methods to optimize the measurement:

Calibration fails
  • Check the connection from the signal generator to the R&S FSW.
  • Check the settings on the signal generator.
  • Check the input signal at the R&S FSW.
No trace visible in "Magnitude Reference" and "Phase Reference" windows
  • No calibration data is available, perform a calibration measurement (without the DUT) or load stored calibration data.
No trace visible in "Group Delay" window
  • No calibration data is available, perform a calibration measurement (without the DUT) or load stored calibration data.
  • MCGD configuration is not compatible to the current calibration (reference) data. Perform a new calibration or adjust measurement settings to fit the calibration data (see "Calibration").
Group delay results are not calculated correctly
  • Check the connections from the DUT to the R&S FSW and to the signal generator.
  • Repeat the calibration measurement (without the DUT) or load stored calibration data from the same measurement setup.
  • Check if the MCGD configuration on the R&S FSW fits to the signal sent by the generator.
  • Connect an external reference to the R&S FSW to improve accuracy (see the R&S FSW User Manual).
  • Check level settings on both the signal generator in use and the R&S FSW MCGD application. Increase the generator’s output level and adjust the reference level of the MCGD application accordingly.
  • Check the measurement time. Longer measurement times result in better signal to noise ratios in the group delay calculation. The "Meas Time Auto" mode should provide a suitable value in most cases (see "Measurement Time").
  • For absolute group delay calculation an external trigger has to be used. Check whether an external trigger is connected and is being sent to the R&S FSW. The trigger periodicity has to be an integer multiple of the signal's periodicity, which is 1/carrier spacing.
  • Increase the sweep count for absolute group delay calculation (for example 100 sweeps) to improve the measurement result. Use the sweep count for calibration as well as for group delay measurement (trace averaging) to compensate for trigger inaccuracies.
  • Increase the carrier spacing on the used multi-carrier signal to reduce noise in the group delay calculation. Reducing the carrier spacing for multi-carrier signals leads to a better frequency resolution, but also causes more noise in the calculated group delay.
  • For very low signal levels and short measurement times, the frequency estimation used by the MCGD application to determine the exact position of the carriers can degrade the measurement result due to uncompensated intercarrier interference. Increase the signal generator’s output level. Alternatively, you can select the carrier offset mode "Fixed". In this case, frequency estimation is disabled and the carrier offset is set to a fixed value: 0 Hz for odd number of carriers and carrier spacing / 2 for even number of carriers accordingly.
Contents
  • Error and Status Messages


Error and Status Messages

Multi-Carrier Group Delay (R&S FSW-K17) > Optimizing and Troubleshooting the Measurement > Error and Status Messages
Error and Status Messages

Error messages are entered in the error/event queue of the status reporting system in the remote control mode and can be queried with the command SYSTem:ERRor?.

Warnings are not indicated in the status reporting system, but are displayed in the status bar. A short explanation of the warning messages for the R&S FSW MCGD application is given below.

Status messages for the R&S FSW MCGD application
Status bar message | Description
"No calibration data" | The calibration measurement has not yet been performed, nor have stored settings been loaded.
"Measurement configuration not compatible to Calibration Data" | MCGD configuration contains a setting that is not compatible to the current calibration (reference) data. Solution: Repeat the calibration measurement (without the DUT) or change the measurement settings.


Remote Commands to Perform Multi-Carrier Group Delay Measurements

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements
Remote Commands to Perform Multi-Carrier Group Delay Measurements

The following commands are required to perform measurements in the Multi-Carrier Group Delay application in a remote environment. It is assumed that the R&S FSW has already been set up for remote operation in a network as described in the R&S FSW User Manual.

(See "How to Set Up a Network and Remote Control" .)

Note that basic tasks that are also performed in the base unit in the same way are not described here.

In particular, this includes:

  • Managing Settings and Results, i.e. storing and loading settings and result data, see "Managing Settings and Results"
  • Basic instrument configuration, e.g. checking the system configuration, customizing the screen layout, or configuring networks and remote operation, see "Configuring the "
  • Using the common status registers, see "Using the Status Register"

The following topics specific to Multi-Carrier Group Delay application are described here:

Contents
  • Introduction
  • Common Suffixes
  • Activating Multi-Carrier Group Delay Measurements
  • Configuring Multi-Carrier Group Delay Measurements
  • Measuring, Loading and Storing Calibration Data
  • Configuring the Result Display
  • Configuring and Performing Sweeps
  • Retrieving Results
  • Analyzing Multi-Carrier Group Delay Measurements
  • Commands for Compatibility


Introduction

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction
Introduction

Commands are program messages that a controller (e.g. a PC) sends to the instrument or software. They operate its functions ('setting commands' or 'events') and request information ('query commands'). Some commands can only be used in one way, others work in two ways (setting and query). If not indicated otherwise, the commands can be used for settings and queries.

The syntax of a SCPI command consists of a header and, in most cases, one or more parameters. To use a command as a query, you have to append a question mark after the last header element, even if the command contains a parameter.

A header contains one or more keywords, separated by a colon. Header and parameters are separated by a "white space" (ASCII code 0 to 9, 11 to 32 decimal, e.g. blank). If there is more than one parameter for a command, these are separated by a comma from one another.

Only the most important characteristics that you need to know when working with SCPI commands are described here. For a more complete description, refer to the User Manual of the R&S FSW.

Remote command examples

Note that some remote command examples mentioned in this general introduction may not be supported by this particular application.

Contents
  • Long and Short Form
  • Numeric Suffixes
  • Optional Keywords
  • Alternative Keywords
  • SCPI Parameters


Long and Short Form

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > Long and Short Form
Long and Short Form

The keywords have a long and a short form. You can use either the long or the short form, but no other abbreviations of the keywords.

The short form is emphasized in upper case letters. Note however, that this emphasis only serves the purpose to distinguish the short from the long form in the manual. For the instrument, the case does not matter.

Example:

SENSe:FREQuency:CENTer is the same as SENS:FREQ:CENT.


Numeric Suffixes

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > Numeric Suffixes
Numeric Suffixes

Some keywords have a numeric suffix if the command can be applied to multiple instances of an object. In that case, the suffix selects a particular instance (e.g. a measurement window).

Numeric suffixes are indicated by angular brackets (<n>) next to the keyword.

If you don't quote a suffix for keywords that support one, a 1 is assumed.

Example:

DISPlay[:WINDow<1...4>]:ZOOM:STATe enables the zoom in a particular measurement window, selected by the suffix at WINDow.

DISPlay:WINDow4:ZOOM:STATe ON refers to window 4.


Optional Keywords

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > Optional Keywords
Optional Keywords

Some keywords are optional and are only part of the syntax because of SCPI compliance. You can include them in the header or not.

Note that if an optional keyword has a numeric suffix and you need to use the suffix, you have to include the optional keyword. Otherwise, the suffix of the missing keyword is assumed to be the value 1.

Optional keywords are emphasized with square brackets.

Example:

Without a numeric suffix in the optional keyword:

[SENSe:]FREQuency:CENTer is the same as FREQuency:CENTer

With a numeric suffix in the optional keyword:

DISPlay[:WINDow<1...4>]:ZOOM:STATe

DISPlay:ZOOM:STATe ON enables the zoom in window 1 (no suffix).

DISPlay:WINDow4:ZOOM:STATe ON enables the zoom in window 4.


Alternative Keywords

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > Alternative Keywords
Alternative Keywords

A vertical stroke indicates alternatives for a specific keyword. You can use both keywords to the same effect.

Example:

[SENSe:]BANDwidth|BWIDth[:RESolution]

In the short form without optional keywords, BAND 1MHZ would have the same effect as BWID 1MHZ.


SCPI Parameters

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > SCPI Parameters
SCPI Parameters

Many commands feature one or more parameters.

If a command supports more than one parameter, these are separated by a comma.

Example:

LAYout:ADD:WINDow Spectrum,LEFT,MTABle

Parameters may have different forms of values.

Contents
  • Numeric Values
  • Boolean
  • Character Data
  • Character Strings
  • Block Data


Numeric Values

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > SCPI Parameters > Numeric Values
Numeric Values

Numeric values can be entered in any form, i.e. with sign, decimal point or exponent. In case of physical quantities, you can also add the unit. If the unit is missing, the command uses the basic unit.

Example:

with unit: SENSe:FREQuency:CENTer 1GHZ

without unit: SENSe:FREQuency:CENTer 1E9 would also set a frequency of 1 GHz.

Values exceeding the resolution of the instrument are rounded up or down.

If the number you have entered is not supported (e.g. in case of discrete steps), the command returns an error.

Instead of a number, you can also set numeric values with a text parameter in special cases.

  • MIN/MAX
    Defines the minimum or maximum numeric value that is supported.
  • DEF
    Defines the default value.
  • UP/DOWN
    Increases or decreases the numeric value by one step. The step size depends on the setting. In some cases you can customize the step size with a corresponding command.
Querying numeric values

When you query numeric values, the system returns a number. In case of physical quantities, it applies the basic unit (e.g. Hz in case of frequencies). The number of digits after the decimal point depends on the type of numeric value.

Example:

Setting: SENSe:FREQuency:CENTer 1GHZ

Query: SENSe:FREQuency:CENTer? would return 1E9

In some cases, numeric values may be returned as text.

  • INF/NINF
    Infinity or negative infinity. Represents the numeric values 9.9E37 or -9.9E37.
  • NAN
    Not a number. Represents the numeric value 9.91E37. NAN is returned in case of errors.


Boolean

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > SCPI Parameters > Boolean
Boolean

Boolean parameters represent two states. The "ON" state (logically true) is represented by "ON" or a numeric value 1. The "OFF" state (logically untrue) is represented by "OFF" or the numeric value 0.

Querying boolean parameters

When you query boolean parameters, the system returns either the value 1 ("ON") or the value 0 ("OFF").

Example:

Setting: DISPlay:WINDow:ZOOM:STATe ON

Query: DISPlay:WINDow:ZOOM:STATe? would return 1


Character Data

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > SCPI Parameters > Character Data
Character Data

Character data follows the syntactic rules of keywords. You can enter text using a short or a long form. For more information see "Long and Short Form".

Querying text parameters

When you query text parameters, the system returns its short form.

Example:

Setting: SENSe:BANDwidth:RESolution:TYPE NORMal

Query: SENSe:BANDwidth:RESolution:TYPE? would return NORM


Character Strings

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > SCPI Parameters > Character Strings
Character Strings

Strings are alphanumeric characters. They have to be in straight quotation marks. You can use a single quotation mark ( ' ) or a double quotation mark ( " ).

Example:

INSTRument:DELete 'Spectrum'


Block Data

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Introduction > SCPI Parameters > Block Data
Block Data

Block data is a format which is suitable for the transmission of large amounts of data.

The ASCII character # introduces the data block. The next number indicates how many of the following digits describe the length of the data block. In the example the 4 following digits indicate the length to be 5168 bytes. The data bytes follow. During the transmission of these data bytes all end or other control signs are ignored until all bytes are transmitted. #0 specifies a data block of indefinite length. The use of the indefinite format requires a NL^END message to terminate the data block. This format is useful when the length of the transmission is not known or if speed or other considerations prevent segmentation of the data into blocks of definite length.


Common Suffixes

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Common Suffixes
Common Suffixes

In the Multi-Carrier Group Delay application, the following common suffixes are used in remote commands:

Suffix | Value range | Description
<m> | 1..16 | Marker
<n> | 1..6 | Window
<t> | 1..4 | Trace


Activating Multi-Carrier Group Delay Measurements

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Activating Multi-Carrier Group Delay Measurements
Activating Multi-Carrier Group Delay Measurements

Multi-Carrier Group Delay measurements requires a special application on the R&S FSW. A measurement is started immediately with the default settings.

List of Commands
INSTrument:CREate:DUPLicate
INSTrument:CREate[:NEW]
INSTrument:CREate:REPLace
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
SYSTem:PRESet:CHANnel[:EXECute]


INSTrument:CREate:DUPLicate

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Activating Multi-Carrier Group Delay Measurements > INSTrument:CREate:DUPLicate
INSTrument:CREate:DUPLicate

This command duplicates the currently selected measurement channel, i.e starts a new measurement channel of the same type and with the identical measurement settings. The name of the new channel is the same as the copied channel, extended by a consecutive number (e.g. "Spectrum" -> "Spectrum 2").

The channel to be duplicated must be selected first using the INST:SEL command.

(See INSTrument[:​SELect] ).

Example: | INST:SEL 'Spectrum' INST:CRE:DUPL Duplicates the channel named 'Spectrum' and creates a new measurement channel named 'Spectrum 2'.
Usage: | Event


INSTrument:CREate[:NEW]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Activating Multi-Carrier Group Delay Measurements > INSTrument:CREate[:NEW]
INSTrument:CREate[:NEW] <ChannelType>, <ChannelName>

This command adds an additional measurement channel. The number of measurement channels you can configure at the same time depends on available memory.

Parameters:
<ChannelType>

Channel type of the new channel.

For a list of available channel types see INSTrument:​LIST?.

<ChannelName>

String containing the name of the channel. The channel name is displayed as the tab label for the measurement channel.

Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).

Example: INST:CRE SAN, 'Spectrum 2'

Adds an additional spectrum display named "Spectrum 2".

Example:

See "I/Q Analysis with Graphical Evaluation" .

Example:

See "Programming Example: Performing a Sequence of Measurements" .


INSTrument:CREate:REPLace

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Activating Multi-Carrier Group Delay Measurements > INSTrument:CREate:REPLace
INSTrument:CREate:REPLace <ChannelName1>,<ChannelType>,<ChannelName2>

This command replaces a measurement channel with another one.

Parameters:
<ChannelName1> | String containing the name of the measurement channel you want to replace.
<ChannelType> | Channel type of the new channel. For a list of available channel types see INSTrument:​LIST?.
<ChannelName2> | String containing the name of the new channel. Note: If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel (see INSTrument:​LIST?).
Example: | INST:CRE:REPL 'Spectrum2',IQ,'IQAnalyzer' Replaces the channel named 'Spectrum2' by a new measurement channel of type 'IQ Analyzer' named 'IQAnalyzer'.


INSTrument:DELete

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Activating Multi-Carrier Group Delay Measurements > INSTrument:DELete
INSTrument:DELete <ChannelName>

This command deletes a measurement channel. If you delete the last measurement channel, the default "Spectrum" channel is activated.

Parameters:
<ChannelName> | String containing the name of the channel you want to delete. A measurement channel must exist in order to be able delete it.
Example: | INST:DEL 'Spectrum4' Deletes the spectrum channel with the name 'Spectrum4'.


INSTrument:LIST?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Activating Multi-Carrier Group Delay Measurements > INSTrument:LIST?
INSTrument:LIST?

This command queries all active measurement channels. This is useful in order to obtain the names of the existing measurement channels, which are required in order to replace or delete the channels.

Return values:
<ChannelType>, <ChannelName> | For each channel, the command returns the channel type and channel name (see tables below). Tip: to change the channel name, use the INSTrument:​REName command.
Example: | INST:LIST? Result for 3 measurement channels: 'ADEM','Analog Demod','IQ','IQ Analyzer','SANALYZER','Spectrum'
Usage: | Query only
Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode
Application | <ChannelType> Parameter | Default Channel Name*)
Spectrum | SANALYZER | Spectrum
I/Q Analyzer | IQ | IQ Analyzer
Pulse (R&S FSW-K6) | PULSE | Pulse
Analog Demodulation (R&S FSW-K7) | ADEM | Analog Demod
GSM (R&S FSW-K10) | GSM | GSM
Multi-Carrier Group Delay (R&S FSW-K17) | MCGD | MC Group Delay
Noise (R&S FSW-K30) | NOISE | Noise
Phase Noise (R&S FSW-K40) | PNOISE | Phase Noise
Transient Analysis (R&S FSW-K60) | TA | Transient Analysis
VSA (R&S FSW-K70) | DDEM | VSA
3GPP FDD BTS (R&S FSW-K72) | BWCD | 3G FDD BTS
3GPP FDD UE (R&S FSW-K73) | MWCD | 3G FDD UE
TD-SCDMA BTS (R&S FSW-K76) | BTDS | TD-SCDMA BTS
TD-SCDMA UE (R&S FSW-K77) | MTDS | TD-SCDMA UE
cdma2000 BTS (R&S FSW-K82) | BC2K | CDMA2000 BTS
cdma2000 MS (R&S FSW-K83) | MC2K | CDMA2000 MS
1xEV-DO BTS (R&S FSW-K84) | BDO | 1xEV-DO BTS
1xEV-DO MS (R&S FSW-K85) | MDO | 1xEV-DO MS
WLAN (R&S FSW-K91) | WLAN | WLAN
LTE (R&S FSW-K10x) | LTE | LTE
Realtime Spectrum (R&S FSW-K160R) | RTIM | Realtime Spectrum
Note: the default channel name is also listed in the table. If the specified name for a new channel already exists, the default name, extended by a sequential number, is used for the new channel.


INSTrument:REName

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Activating Multi-Carrier Group Delay Measurements > INSTrument:REName
INSTrument:REName <ChannelName1>, <ChannelName2>

This command renames a measurement channel.

Parameters:
<ChannelName1> | String containing the name of the channel you want to rename.
<ChannelName2> | String containing the new channel name. Note that you can not assign an existing channel name to a new channel; this will cause an error.
Example: | INST:REN 'Spectrum2','Spectrum3' Renames the channel with the name 'Spectrum2' to 'Spectrum3'.


INSTrument[:SELect]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Activating Multi-Carrier Group Delay Measurements > INSTrument[:SELect]
INSTrument[:SELect] <ChannelType> | <ChannelName>

This command activates a new measurement channel with the defined channel type, or selects an existing measurement channel with the specified name.

See also INSTrument:​CREate[:​NEW].

Parameters:
<ChannelType> | MCGD Multi-Carrier Group Delay application, R&S FSW-K17 For a list of available channel types see table "Available measurement channel types and default channel names in Signal and Spectrum Analyzer mode".
<ChannelName> | String containing the name of the channel.


SYSTem:PRESet:CHANnel[:EXECute]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Activating Multi-Carrier Group Delay Measurements > SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:PRESet:CHANnel[:EXECute]

This command restores the default instrument settings in the current channel.

Use INST:SEL to select the channel.

For details see "Factory Default Configuration" .

Example: | INST 'Spectrum2' Selects the channel for "Spectrum2". SYST:PRES:CHAN:EXEC Restores the factory default settings to the "Spectrum2" channel.
Usage: | Event
Manual operation: | See "Preset Channel"


Configuring Multi-Carrier Group Delay Measurements

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements
Configuring Multi-Carrier Group Delay Measurements

The commands required to configure a Multi-Carrier Group Delay measurement in a remote environment are described here.

Contents
  • RF Input
  • Configuring the Vertical Axis (Amplitude, Scaling)
  • Frequency
  • Triggering Measurements
  • Multi-Carrier Configuration
  • Configuring the Outputs
  • Automatic Settings


RF Input

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > RF Input
RF Input
List of Commands
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:IMPedance
INPut:SELect


INPut:ATTenuation:PROTection:RESet

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > RF Input > INPut:ATTenuation:PROTection:RESet
INPut:ATTenuation:PROTection:RESet

This command resets the attenuator and reconnects the RF input with the input mixer after an overload condition occured and the protection mechanism intervened.The error status bit (bit 3 in the STAT:QUES:POW status register) and the INPUT OVLD message in the status bar are cleared.

(For details on the status register see the R&S FSW User Manual).

The command works only if the overload condition has been eliminated first.

Usage: Event


INPut:COUPling

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > RF Input > INPut:COUPling
INPut:COUPling <CouplingType>

This command selects the coupling type of the RF input.

Parameters:
<CouplingType>
AC

AC coupling

DC

DC coupling

*RST: AC
Example: INP:COUP DC
Usage: SCPI confirmed
Manual operation: See "Input Coupling"


INPut:FILTer:HPASs[:STATe]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > RF Input > INPut:FILTer:HPASs[:STATe]
INPut:FILTer:HPASs[:STATe] <State>

Activates an additional internal high-pass filter for RF input signals from 1 GHz to 3 GHz. This filter is used to remove the harmonics of the R&S FSW in order to measure the harmonics for a DUT, for example.

This function requires option R&S FSW-B13.

(Note: for RF input signals outside the specified range, the high-pass filter has no effect. For signals with a frequency of approximately 4 GHz upwards, the harmonics are suppressed sufficiently by the YIG filter.)

Parameters:
<State>
ON | OFF
*RST: OFF
Usage: SCPI confirmed
Manual operation: See "High-Pass Filter 1...3 GHz"


INPut:FILTer:YIG[:STATe]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > RF Input > INPut:FILTer:YIG[:STATe]
INPut:FILTer:YIG[:STATe] <State>

This command turns the YIG-preselector on and off.

Note the special conditions and restrictions for the YIG filter described in "YIG-Preselector".

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1 (0 for I/Q Analyzer, GSM, VSA and MC Group Delay measurements)
Example: INP:FILT:YIG OFF

Deactivates the YIG-preselector.

Manual operation: See "YIG-Preselector"


INPut:IMPedance

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > RF Input > INPut:IMPedance
INPut:IMPedance <Impedance>

This command selects the nominal input impedance of the RF input.

75 Ω should be selected if the 50 Ω input impedance is transformed to a higher impedance using a matching pad of the RAZ type (= 25 Ω in series to the input impedance of the instrument). The power loss correction value in this case is 1.76 dB = 10 log (75Ω/50Ω).

Parameters:
<Impedance>
50 | 75
*RST: 50 Ω
Example: INP:IMP 75
Usage: SCPI confirmed
Manual operation: See "Impedance"


INPut:SELect

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > RF Input > INPut:SELect
INPut:SELect <Source>

This command selects the signal source for measurements, i.e. it defines which connector is used to input data to the R&S FSW. If no additional options are installed, only RF input is supported.

Parameters:
<Source>
RF

Radio Frequency ("RF INPUT" connector)

*RST: RF
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .


Configuring the Vertical Axis (Amplitude, Scaling)

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling)
Configuring the Vertical Axis (Amplitude, Scaling)

The following commands are required to configure the amplitude and vertical axis settings in a remote environment.

Contents
  • Amplitude Settings
  • Attenuation
  • Configuring a Preamplifier
  • Scaling the Y-Axis (+Units)


Amplitude Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings
Amplitude Settings
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel <ReferenceLevel>

This command defines the reference level.

With a reference level offset ≠ 0, the value range of the reference level is modified by the offset.

Parameters:
<ReferenceLevel>

The unit is variable.

Range: | see datasheet
*RST: | 0 dBm
Example: DISP:TRAC:Y:RLEV -60dBm
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Reference Level"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Amplitude Settings > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet <Offset>

This command defines a reference level offset.

Parameters:
<Offset>
Range: | -200 dB to 200 dB
*RST: | 0dB
Example: DISP:TRAC:Y:RLEV:OFFS -10dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Shifting the Display (Offset)"


Attenuation

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Attenuation
Attenuation
List of Commands
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe


INPut:ATTenuation

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Attenuation > INPut:ATTenuation
INPut:ATTenuation <Attenuation>

This command defines the total attenuation for RF input.

If an electronic attenuator is available and active, the command defines a mechanical attenuation (see INPut:​EATT:​STATe).

If you set the attenuation manually, it is no longer coupled to the reference level, but the reference level is coupled to the attenuation. Thus, if the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
Range: | see data sheet
Increment: | 5 dB
*RST: | 10 dB (AUTO is set to ON)
Example: INP:ATT 30dB

Defines a 30 dB attenuation and decouples the attenuation from the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:ATTenuation:AUTO

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Attenuation > INPut:ATTenuation:AUTO
INPut:ATTenuation:AUTO <State>

This command couples or decouples the attenuation to the reference level. Thus, when the reference level is changed, the R&S FSW determines the signal level for optimal internal data processing and sets the required attenuation accordingly.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:ATT:AUTO ON

Couples the attenuation to the reference level.

Usage: SCPI confirmed
Manual operation: See "Attenuation Mode / Value"


INPut:EATT

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Attenuation > INPut:EATT
INPut:EATT <Attenuation>

This command defines an electronic attenuation manually. Automatic mode must be switched off (INP:EATT:AUTO OFF, see INPut:​EATT:​AUTO).

If the current reference level is not compatible with an attenuation that has been set manually, the command also adjusts the reference level.

Parameters:
<Attenuation>
attenuation in dB
Range: | see data sheet
Increment: | 1 dB
*RST: | 0 dB (OFF)
Example: INP:EATT:AUTO OFF
INP:EATT 10 dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:AUTO

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Attenuation > INPut:EATT:AUTO
INPut:EATT:AUTO <State>

This command turns automatic selection of the electronic attenuation on and off.

If on, electronic attenuation reduces the mechanical attenuation whenever possible.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: INP:EATT:AUTO OFF
Manual operation: See "Using Electronic Attenuation (Option B25)"


INPut:EATT:STATe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Attenuation > INPut:EATT:STATe
INPut:EATT:STATe <State>

This command turns the electronic attenuator on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:EATT:STAT ON

Switches the electronic attenuator into the signal path.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Using Electronic Attenuation (Option B25)"


Configuring a Preamplifier

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier
Configuring a Preamplifier
List of Commands
INPut:GAIN:STATe
INPut:GAIN[:VALue]


INPut:GAIN:STATe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN:STATe
INPut:GAIN:STATe <State>

This command turns the preamplifier on and off.

The command requires option R&S FSW-B24.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: INP:GAIN:STAT ON

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


INPut:GAIN[:VALue]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Configuring a Preamplifier > INPut:GAIN[:VALue]
INPut:GAIN[:VALue] <Gain>

This command selects the preamplification level if the preamplifier is activated (INP:GAIN:STAT ON, see INPut:​GAIN:​STATe).

The command requires option R&S FSW-B24.

Parameters:
<Gain>
15 dB | 30 dB

The availability of preamplification levels depends on the R&S FSW model.

R&S FSW8/13: 15dB and 30 dB

R&S FSW26 or higher: 30 dB

All other values are rounded to the nearest of these two.

*RST: OFF
Example: INP:GAIN:VAL 30

Switches on 30 dB preamplification.

Usage: SCPI confirmed
Manual operation: See "Preamplifier (option B24)"


Scaling the Y-Axis (+Units)

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units)
Scaling the Y-Axis (+Units)
List of Commands
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y:SPACing
UNIT:ANGLe


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units) > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe] <Range>

This command defines the display range of the y-axis.

Example: DISP:TRAC:Y 110dB
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Range"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units) > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum <Value>

This command defines the maximum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Defining Min and Max Values"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units) > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum <Value>

This command defines the minimum value of the y-axis for the selected result display.

Parameters:
<Value>
<numeric value>
*RST: depends on the result display

The unit and range depend on the result display.

Example: DISP:TRAC:Y:MIN -60
DISP:TRAC:Y:MAX 0

Defines the y-axis with a minimum value of -60 and maximum value of 0.

Manual operation: See "Defining Min and Max Values"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units) > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE <Mode>

This command selects the type of scaling of the y-axis.

When the display update during remote control is off, this command has no immediate effect.

Parameters:
<Mode>
ABSolute

absolute scaling of the y-axis

RELative

relative scaling of the y-axis

*RST: ABSolute
Example: DISP:TRAC:Y:MODE REL
Manual operation: See "Scaling"
See "Scale Mode"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units) > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision <Value>

This remote command determines the grid spacing on the Y-axis for all diagrams, where possible.

Parameters:
<Value>
numeric value WITHOUT UNIT (unit according to the result display)

Defines the range per division (total range = 10*<Value>)

*RST: depends on the result display
Example: DISP:TRAC:Y:PDIV 10

Sets the grid spacing to 10 units (e.g. dB) per division

Manual operation: See "Range per Division"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units) > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition <Position>

This command defines the vertical position of the reference level on the display grid.

The R&S FSW adjusts the scaling of the y-axis accordingly.

Parameters:
<Position>

0 PCT corresponds to the lower display border, 100% corresponds to the upper display border.

*RST: 100 PCT = frequency display; 50 PCT = time display
Example:

DISP:TRAC:Y:RPOS 50PCT

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Ref Level Position"
See "Y-Axis Reference Position"


DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units) > DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue <Value>

The command defines the power value assigned to the reference position in the grid.

For external generator calibration measurements (requires External Generator Control option R&S FSW-B10), this command defines the power offset value assigned to the reference position.

Parameters:
<Value>
*RST: 0 dBm, coupled to reference level
Example: DISP:TRAC:Y:RVAL -20dBm

Sets the power value assigned to the reference position to -20 dBm

Manual operation: See "Y-Axis Reference Value"


DISPlay[:WINDow<n>]:TRACe:Y:SPACing

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units) > DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y:SPACing <ScalingType>

This command selects the scaling of the y-axis.

Parameters:
<ScalingType>
LOGarithmic

Logarithmic scaling.

LINear

Linear scaling in %.

LDB

Linear scaling in the specified unit.

PERCent

Linear scaling in %.

*RST: LOGarithmic
Example: DISP:TRAC:Y:SPAC LIN

Selects linear scaling in %.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Scaling"


UNIT:ANGLe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Vertical Axis (Amplitude, Scaling) > Scaling the Y-Axis (+Units) > UNIT:ANGLe
UNIT:ANGLe <Unit>

This command selects the unit for angles (for phase display).

Parameters:
<Unit>
DEG | RAD
*RST: DEG
Example:

UNIT:ANGL DEG

Manual operation: See "Phase Unit (Rad/Deg)"


Frequency

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Frequency
Frequency
List of Commands
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet


[SENSe:]FREQuency:CENTer

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Frequency > [SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer <Frequency>

This command defines the center frequency.

Parameters:
<Frequency>

The allowed range and fmax is specified in the data sheet.

UP

Increases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

DOWN

Decreases the center frequency by the step defined using the [SENSe:​]FREQuency:​CENTer:​STEP command.

*RST: | fmax/2
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Center frequency"


[SENSe:]FREQuency:CENTer:STEP

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Frequency > [SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP <StepSize>

This command defines the center frequency step size.

You can increase or decrease the center frequency quickly in fixed steps using the SENS:FREQ UP AND SENS:FREQ DOWN commands, see [SENSe:​]FREQuency:​CENTer.

Parameters:
<StepSize>

fmax is specified in the data sheet.

Range: | 1 to fMAX
*RST: | 0.1 x span
Default unit: | Hz
Example: FREQ:CENT 100 MHz
FREQ:CENT:STEP 10 MHz
FREQ:CENT UP

Sets the center frequency to 110 MHz.

Manual operation: See "Center Frequency Stepsize"


[SENSe:]FREQuency:CENTer:STEP:AUTO

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Frequency > [SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:AUTO <State>

This command couples or decouples the center frequency step size to the span.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: 1
Example: FREQ:CENT:STEP:AUTO ON

Activates the coupling of the step size to the span.


[SENSe:]FREQuency:CENTer:STEP:LINK

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Frequency > [SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK <CouplingType>

This command couples and decouples the center frequency step size to the span or the resolution bandwidth.

Parameters:
<CouplingType>
SPAN

Couples the step size to the span. Available for measurements in the frequency domain.

OFF

Decouples the step size.

*RST: SPAN
Example: FREQ:CENT:STEP:LINK SPAN


[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Frequency > [SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor <Factor>

This command defines a step size factor if the center frequency step size is coupled to the span.

Parameters:
<Factor>
1 to 100 PCT
*RST: 10
Example: FREQ:CENT:STEP:LINK:FACT 20PCT


[SENSe:]FREQuency:OFFSet

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Frequency > [SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:OFFSet <Offset>

This command defines a frequency offset.

If this value is not 0 Hz, the application assumes that the input signal was frequency shifted outside the application. All results of type "frequency" will be corrected for this shift numerically by the application.

See also "Frequency Offset".

Parameters:
<Offset>
Range: | -100 GHz to 100 GHz
*RST: | 0 Hz
Example: FREQ:OFFS 1GHZ
Usage: SCPI confirmed
Manual operation: See "Frequency Offset"


Triggering Measurements

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements
Triggering Measurements
Useful commands for triggering described elsewhere:
  • [SENSe:​]FREQuency:​CENTer
Remote commands exclusive to triggering:
Contents
  • Configuring the Triggering Conditions
  • Configuring the Trigger Output


Configuring the Triggering Conditions

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions
Configuring the Triggering Conditions
List of Commands
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce


TRIGger[:SEQuence]:DTIMe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:DTIMe <DropoutTime>

Defines the time the input signal must stay below the trigger level before a trigger is detected again.

Parameters:
<DropoutTime>

Dropout time of the trigger.

Range: | 0 s to 10.0 s
*RST: | 0 s
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Drop-Out Time"


TRIGger[:SEQuence]:HOLDoff[:TIME]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:HOLDoff[:TIME] <Offset>

Defines the time offset between the trigger event and the start of the sweep (data capturing).

Parameters:
<Offset>
*RST: 0 s
Example: TRIG:HOLD 500us
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Offset"


TRIGger[:SEQuence]:IFPower:HOLDoff

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HOLDoff <Period>

This command defines the holding time before the next trigger event.

Note that this command can be used for any trigger source, not just IF Power (despite the legacy keyword).

Parameters:
<Period>
Range: | 0 s to 10 s
*RST: | 0 s
Example: TRIG:SOUR EXT

Sets an external trigger source.

TRIG:IFP:HOLD 200 ns

Sets the holding time to 200 ns.

Manual operation: See "Trigger Holdoff"


TRIGger[:SEQuence]:IFPower:HYSTeresis

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:IFPower:HYSTeresis <Hysteresis>

This command defines the trigger hysteresis, which is only available for "IF Power" trigger sources.

Parameters:
<Hysteresis>
Range: | 3 dB to 50 dB
*RST: | 3 dB
Example: TRIG:SOUR IFP

Sets the IF power trigger source.

TRIG:IFP:HYST 10DB

Sets the hysteresis limit value.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Hysteresis"


TRIGger[:SEQuence]:LEVel[:EXTernal<port>]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:LEVel[:EXTernal<port>] <TriggerLevel>

This command defines the level the external signal must exceed to cause a trigger event.

Note that the variable INPUT/OUTPUT connectors (ports 2+3) must be set for use as input using the OUTPut:​TRIGger<port>:​DIRection command.

Suffix:
<port>

Selects the trigger port.

1 = trigger port 1 (TRIGGER INPUT connector on front panel)

2 = trigger port 2 (TRIGGER INPUT/OUTPUT connector on front panel)

3 = trigger port 3 (TRIGGER3 INPUT/OUTPUT connector on rear panel)

Parameters:
<TriggerLevel>
Range: | 0.5 V to 3.5 V
*RST: | 1.4 V
Example: TRIG:LEV 2V
Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:IFPower

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IFPower <TriggerLevel>

This command defines the power level at the third intermediate frequency that must be exceeded to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -10 dBm
Example: TRIG:LEV:IFP -30DBM
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:IQPower

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:IQPower <TriggerLevel>

This command defines the magnitude the I/Q data must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed.

Parameters:
<TriggerLevel>
Range: | -130 dBm to 30 dBm
*RST: | -20 dBm
Example: TRIG:LEV:IQP -30DBM
Example:

See "Basic I/Q Analysis with Improved Performance" .

Manual operation: See "Trigger Level"


TRIGger[:SEQuence]:LEVel:RFPower

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel:RFPower <TriggerLevel>

This command defines the power level the RF input must exceed to cause a trigger event. Note that any RF attenuation or preamplification is considered when the trigger level is analyzed. If defined, a reference level offset is also considered.

The input signal must be between 500 MHz and 8 GHz.

Parameters:
<TriggerLevel>

For details on available trigger levels and trigger bandwidths see the data sheet.

*RST: -20 dBm
Example: TRIG:LEV:RFP -30dBm


TRIGger[:SEQuence]:RFPower:HOLDoff

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:RFPower:HOLDoff <Time>

This command defines the holding time before the next trigger event. Note that this command is available for any trigger source, not just RF Power.

Note that this command is maintained for compatibility reasons only. Use the TRIGger[:​SEQuence]:​IFPower:​HOLDoff command for new remote control programs.

Parameters:
<Time>
Default unit: S


TRIGger[:SEQuence]:SLOPe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SLOPe <Type>

For external and time domain trigger sources you can define whether triggering occurs when the signal rises to the trigger level or falls down to it.

Parameters:
<Type>
POSitive | NEGative
POSitive

Triggers when the signal rises to the trigger level (rising edge).

NEGative

Triggers when the signal drops to the trigger level (falling edge).

*RST: POSitive
Example: TRIG:SLOP NEG
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Slope"


TRIGger[:SEQuence]:SOURce

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Triggering Conditions > TRIGger[:SEQuence]:SOURce
TRIGger[:SEQuence]:SOURce <Source>

This command selects the trigger source.

Note on external triggers:

If a measurement is configured to wait for an external trigger signal in a remote control program, remote control is blocked until the trigger is received and the program can continue. Make sure this situation is avoided in your remote control programs.

Parameters:
<Source>
IMMediate

Free Run

EXTernal

Trigger signal from the TRIGGER INPUT connector.

EXT2

Trigger signal from the TRIGGER INPUT/OUTPUT connector.

Note: Connector must be configured for "Input".

EXT3

Trigger signal from the TRIGGER 3 INPUT/ OUTPUT connector.

Note: Connector must be configured for "Input".

RFPower

First intermediate frequency

IFPower

Second intermediate frequency

IQPower

Magnitude of sampled I/Q data

For applications that process I/Q data, such as the I/Q Analyzer or optional applications.

*RST: IMMediate
Example: TRIG:SOUR EXT

Selects the external trigger input as source of the trigger signal

Example:

See "Basic I/Q Analysis with Improved Performance" .

Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Example:

See "Data Acquisition via the Optional Analog Baseband Interface (-B71)" .

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Example:

See "Programming Example" .

Manual operation: See "Trigger Source"
See "Free Run"
See "External Trigger 1/2/3"
See "IF Power"
See "RF Power"
See "I/Q Power"


Configuring the Trigger Output

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Trigger Output
Configuring the Trigger Output

The following commands are required to send the trigger signal to one of the variable TRIGGER INPUT/OUTPUT connectors. The tasks for manual operation are described in "Trigger 2/3".

List of Commands
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth


OUTPut:TRIGger<port>:DIRection

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:DIRection <Direction>

This command selects the trigger direction.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Direction>
INPut

Port works as an input.

OUTPut

Port works as an output.

*RST: INPut
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"


OUTPut:TRIGger<port>:LEVel

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:LEVel <Level>

This command defines the level of the signal generated at the trigger output.

This command works only if you have selected a user defined output with OUTPut:​TRIGger<port>:​OTYPe.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Level>
HIGH

TTL signal.

LOW

0 V

*RST: LOW
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Trigger 2/3"
See "Level"


OUTPut:TRIGger<port>:OTYPe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:OTYPe <OutputType>

This command selects the type of signal generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<OutputType>
DEVice

Sends a trigger signal when the R&S FSW has triggered internally.

TARMed

Sends a trigger signal when the trigger is armed and ready for an external trigger event.

UDEFined

Sends a user defined trigger signal. For more information see OUTPut:​TRIGger<port>:​LEVel.

*RST: DEVice
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Output Type"


OUTPut:TRIGger<port>:PULSe:IMMediate

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:IMMediate

This command generates a pulse at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: Event
Manual operation: See "Send Trigger"


OUTPut:TRIGger<port>:PULSe:LENGth

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Triggering Measurements > Configuring the Trigger Output > OUTPut:TRIGger<port>:PULSe:LENGth
OUTPut:TRIGger<port>:PULSe:LENGth <Length>

This command defines the length of the pulse generated at the trigger output.

Suffix:
<port>

Selects the trigger port to which the output is sent.

2 = trigger port 2 (front)

3 = trigger port 3 (rear)

Parameters:
<Length>

Pulse length in seconds.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Pulse Length"


Multi-Carrier Configuration

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration
Multi-Carrier Configuration

The following commands are required to configure the multi-carrier measurement.

List of Commands
CALCulate:GRPDelay:MODE
[SENSe:]BANDwidth:DEMod?
[SENSe:]BWIDth:DEMod?
[SENSe:]CARRier:COUNt
[SENSe:]CARRier:SPACing
[SENSe:]FREQuency:SPAN
[SENSe:]MTIMe:AUTO
[SENSe:]MTIMe?
[SENSe:]CARRier:OFFSet?
[SENSe:]CARRier:OFFSet:MODE
[SENSe:]RLENgth?
[SENSe:]SRATe?


CALCulate:GRPDelay:MODE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > CALCulate:GRPDelay:MODE
CALCulate:GRPDelay:MODE <GroupDelayAbsRel>

This command sets the group delay mode for multi carriers to either absolute or relative or queries its current state.

Parameters:
<GroupDelayAbsRel>
ABSolute | RELative
ABSolute

Calculates the absolute group delay; requires an external trigger

RELative

Calculates the relative group delay; constant delay parts are compensated for

*RST: RELative
Manual operation: See "Group Delay Mode"


[SENSe:]BANDwidth:DEMod?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]BANDwidth:DEMod?
[SENSe:]BANDwidth:DEMod?
[SENSe:]BWIDth:DEMod?

Queries the measurement bandwidth in Hz

Return values:
<Bandwidth>
Default unit: HZ
Usage: Query only


[SENSe:]CARRier:COUNt

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]CARRier:COUNt
[SENSe:]CARRier:COUNt <Count>

Sets/queries the number of carriers.

Parameters:
<Count> |
Manual operation: | See "Number of Carriers"


[SENSe:]CARRier:SPACing

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]CARRier:SPACing
[SENSe:]CARRier:SPACing <CarrierSpacing>

Sets/queries the carrier spacing in Hz between the multiple carriers.

Parameters:
<CarrierSpacing>
Default unit: HZ
Manual operation: See "Carrier Spacing"


[SENSe:]FREQuency:SPAN

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]FREQuency:SPAN
[SENSe:]FREQuency:SPAN <Frequency>

Sets/queries the frequency span in Hz

Parameters:
<Frequency>
Default unit: HZ
Manual operation: See "Span"


[SENSe:]MTIMe:AUTO

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]MTIMe:AUTO
[SENSe:]MTIMe:AUTO <MeasTimeAutoMode>

This command enables or disables automatic measurement time selection.

Parameters:
<MeasTimeAutoMode>
ON | 1

Enables automatic measurement time selection.

OFF | 0

Measurement time is defined manually.

*RST: 1
Manual operation: See "Measurement Time"


[SENSe:]MTIMe?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]MTIMe?
[SENSe:]MTIMe? <MeasTime>

This command queries or sets the measurement time.

Parameters:
<MeasTime>

The measurement time.

*RST: | 5 ms
Default unit: | S
Usage: Query only
Manual operation: See "Measurement Time"


[SENSe:]CARRier:OFFSet?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]CARRier:OFFSet?
[SENSe:]CARRier:OFFSet?

Queries the offset in Hz of the carriers compared to the center frequency.

Return values:
<CarrierOffset>
Range: | - (Carrier spacing / 2) to + (Carrier spacing / 2)
Default unit: | HZ
Usage: Query only
Manual operation: See "Carrier Estimation"


[SENSe:]CARRier:OFFSet:MODE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]CARRier:OFFSet:MODE
[SENSe:]CARRier:OFFSet:MODE <CarrierOffsetMode>

Defines the method used to estimate the carrier frequency when calculating the multi-carrier group delay.

Parameters:
<CarrierOffsetMode>
ESTimate | FIXed | CARRiers
ESTimate

A fixed offset is estimated and used for all carriers.

FIXed

The carrier frequencies as defined in the configuration are used; possible offsets are not compensated.

CARRiers

The frequency offset of each carrier is estimated and compensated when calculating the group delay.

*RST: ESTimate
Manual operation: See "Carrier Estimation"
See "Estimation Type"


[SENSe:]RLENgth?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]RLENgth?
[SENSe:]RLENgth?

This command returns the record length determined by the current measurement settings.

Return values:
<SampleCount> | Number of samples captured in one sweep.
Usage: | Query only


[SENSe:]SRATe?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Multi-Carrier Configuration > [SENSe:]SRATe?
[SENSe:]SRATe?

This command returns the sample rate set up for current measurement settings.

Return values:
<SampleRate> | Current sample rate used by the application.
Usage: | Query only


Configuring the Outputs

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Outputs
Configuring the Outputs

Configuring trigger input/output is described in "Configuring the Trigger Output".

List of Commands
DIAGnostic:SERVice:NSOurce


DIAGnostic:SERVice:NSOurce

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Configuring the Outputs > DIAGnostic:SERVice:NSOurce
DIAGnostic:SERVice:NSOurce <State>

This command turns the 28 V supply of the BNC connector labeled NOISE SOURCE CONTROL on the front panel on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DIAG:SERV:NSO ON
Manual operation: See "Noise Source"


Automatic Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Automatic Settings
Automatic Settings

Some settings can be adjusted by the R&S FSW automatically according to the current measurement settings and signal characteristics.

MSRA operating mode

In MSRA operating mode, the following automatic settings are not available, as they require a new data acquisition. However, the GSM application cannot perform data acquisition in MSRA operating mode.

List of Commands
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel


[SENSe:]ADJust:CONFigure:DURation

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation <Duration>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command defines the length of the measurement if [SENSe:​]ADJust:​CONFigure:​DURation:​MODE is set to MANual.

Parameters:
<Duration>
Numeric value in seconds
Range: | 0.001 to 16000.0
*RST: | 0.001
Default unit: | s
Example: ADJ:CONF:DUR:MODE MAN

Selects manual definition of the measurement length.

ADJ:CONF:LEV:DUR 5ms

Length of the measurement is 5 ms.

Manual operation: See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:DURation:MODE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Automatic Settings > [SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:DURation:MODE <Mode>

In order to determine the ideal reference level, the R&S FSW performs a measurement on the current input data. This command selects the way the R&S FSW determines the length of the measurement .

Parameters:
<Mode>
AUTO

The R&S FSW determines the measurement length automatically according to the current input data.

MANual

The R&S FSW uses the measurement length defined by [SENSe:​]ADJust:​CONFigure:​DURation.

*RST: AUTO
Manual operation: See "Resetting the Automatic Measurement Time (Meastime Auto)"
See "Changing the Automatic Measurement Time (Meastime Manual)"


[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines a lower threshold the signal must fall below (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:LOW 2

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level falls below 18 dBm.

Manual operation: See "Lower Level Hysteresis"


[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Automatic Settings > [SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer <Threshold>

When the reference level is adjusted automatically using the [SENSe:​]ADJust:​LEVel command, the internal attenuators and the preamplifier are also adjusted. In order to avoid frequent adaptation due to small changes in the input signal, you can define a hysteresis. This setting defines an upper threshold the signal must exceed (compared to the last measurement) before the reference level is adapted automatically.

Parameters:
<Threshold>
Range: | 0 dB to 200 dB
*RST: | +1 dB
Default unit: | dB
Example: SENS:ADJ:CONF:HYST:UPP 2
Example:

For an input signal level of currently 20 dBm, the reference level will only be adjusted when the signal level rises above 22 dBm.

Manual operation: See "Upper Level Hysteresis"


[SENSe:]ADJust:LEVel

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring Multi-Carrier Group Delay Measurements > Automatic Settings > [SENSe:]ADJust:LEVel
[SENSe:]ADJust:LEVel

This command initiates a single (internal) measurement that evaluates and sets the ideal reference level for the current input data and measurement settings. This ensures that the settings of the RF attenuation and the reference level are optimally adjusted to the signal level without overloading the R&S FSW or limiting the dynamic range by an S/N ratio that is too small.

Example: | ADJ:LEV
Usage: | Event
Manual operation: | See "Setting the Reference Level Automatically (Auto Level)"


Measuring, Loading and Storing Calibration Data

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Measuring, Loading and Storing Calibration Data
Measuring, Loading and Storing Calibration Data

The folowing commands are required to perform the calibration measurement and load and store the calibration data.

List of Commands
CALibration:MCGD
CALibration:MCGD:STATe?
MMEMory:LOAD:MCGD:RCALibration
MMEMory:STORe:MCGD:RCALibration


CALibration:MCGD

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Measuring, Loading and Storing Calibration Data > CALibration:MCGD
CALibration:MCGD

This command initiates a new calibration. You can synchronize to the end of the measurement as usual with *OPC, *OPC? or *WAI.

Example: | CAL:MCGD;*WAI Performs a calibration measurement and waits for the results.
Usage: | Event
Manual operation: | See "Calibrate (Execute Reference Calibration)"


CALibration:MCGD:STATe?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Measuring, Loading and Storing Calibration Data > CALibration:MCGD:STATe?
CALibration:MCGD:STATe?

This command queries the calibration status of the Multi Carrier Group Delay application.

Return values:
<State> | ON | 1 Calibration has been performed, reference data is available. OFF | 0 Calibration has not yet been performed or is currently running, reference data is not yet available.
Usage: | Query only


MMEMory:LOAD:MCGD:RCALibration

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Measuring, Loading and Storing Calibration Data > MMEMory:LOAD:MCGD:RCALibration
MMEMory:LOAD:MCGD:RCALibration <File>

This command loads the calibration data stored in the selected file and replaces the current data.

Setting parameters:
<File> | path and file name of the .csv file that contains the calibration data
Usage: | Setting only
Manual operation: | See "Loading Calibration Data"


MMEMory:STORe:MCGD:RCALibration

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Measuring, Loading and Storing Calibration Data > MMEMory:STORe:MCGD:RCALibration
MMEMory:STORe:MCGD:RCALibration <File>

This command stores the current calibration data to the selected file.

Setting parameters:
<File> | path and file name of the .csv file that will contain the calibration data
Usage: | Setting only
Manual operation: | See "Storing Calibration Data"


Configuring the Result Display

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display
Configuring the Result Display

The commands required to configure the screen display in a remote environment are described here.

Contents
  • General Window Commands
  • Working with Windows in the Display


General Window Commands

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > General Window Commands
General Window Commands

The following commands are required to configure general window layout, independent of the application.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
DISPlay:FORMat
DISPlay[:WINDow<n>]:SIZE


DISPlay:FORMat

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > General Window Commands > DISPlay:FORMat
DISPlay:FORMat <Format>

This command determines which tab is displayed.

Parameters:
<Format>
SPLit

Displays the MultiView tab with an overview of all active channels

(See "R&S MultiView" ).

SINGle

Displays the measurement channel that was previously focused.

*RST: SING
Example: DISP:FORM SPL


DISPlay[:WINDow<n>]:SIZE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > General Window Commands > DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:SIZE <Size>

This command maximizes the size of the selected result display window temporarily. To change the size of several windows on the screen permanently, use the LAY:SPL command (see LAYout:​SPLitter).

Parameters:
<Size>
LARGe

Maximizes the selected window to full screen.

Other windows are still active in the background.

SMALl

Reduces the size of the selected window to its original size.

If more than one measurement window was displayed originally, these are visible again.

*RST: SMALl
Example: DISP:WIND2:LARG
Example:

See "Example 1: Adding and Arranging Windows" .


Working with Windows in the Display

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display
Working with Windows in the Display

The following commands are required to change the evaluation type and rearrange the screen layout for a measurement channel as you do using the SmartGrid in manual operation. Since the available evaluation types depend on the selected application, some parameters for the following commands also depend on the selected measurement channel.

Note that the suffix <n> always refers to the window in the currently selected measurement channel (see INSTrument[:​SELect]).

List of Commands
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace


LAYout:ADD[:WINDow]?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:ADD[:WINDow]?
LAYout:ADD[:WINDow]? <WindowName>,<Direction>,<WindowType>

This command adds a window to the display.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

To replace an existing window, use the LAYout:​REPLace[:​WINDow] command.

Parameters:
<WindowName>

String containing the name of the existing window the new window is inserted next to.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<Direction>
LEFT | RIGHt | ABOVe | BELow

Direction the new window is added relative to the existing window.

<WindowType>
text value

Type of result display (evaluation method) you want to add.

See the table below for available parameter values.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:ADD? '1',LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

For a detailed example see "Example 1: Adding and Arranging Windows" and "Example 2: Replacing and Removing Windows" .

Example:

See "Programming Example" .

Usage: Query only
Manual operation: See "Magnitude"
See "Phase"
See "Magnitude Reference"
See "Phase Reference"
See "Group Delay"
See "Gain"
See "Marker Table"
<WindowType> parameter values for Multi-Carrier Group Delay (K17) application
Parameter value | Window type
GAIN | Gain
GDELay | Group Delay vs. Frequency
MAGNitude | Magnitude vs. Frequency (Measurement data)
MTABle | Marker table
PHASe | Phase vs Frequency (Measurement data)
RMAGnitude | Magnitude vs. Frequency (Reference data)
RPHase | Phase vs Frequency (Reference data)


LAYout:CATalog[:WINDow]?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:CATalog[:WINDow]?
LAYout:CATalog[:WINDow]?

This command queries the name and index of all active windows from top left to bottom right. The result is a comma-separated list of values for each window, with the syntax:

<WindowName_1>,<WindowIndex_1>..<WindowName_n>,<WindowIndex_n>

Return values:
<WindowName>
string

Name of the window.

In the default state, the name of the window is its index.

<WindowIndex>
numeric value

Index of the window.

Example: LAY:CAT?

Result:

'2',2,'1',1

Two windows are displayed, named '2' (at the top or left), and '1' (at the bottom or right).

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:IDENtify[:WINDow]?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:IDENtify[:WINDow]?
LAYout:IDENtify[:WINDow]? <WindowName>

This command queries the index of a particular display window.

Note: to query the name of a particular window, use the LAYout:​WINDow<n>:​IDENtify? query.

Query parameters:
<WindowName> | String containing the name of a window.
Return values:
<WindowIndex> | Index number of the window.
Usage: | Query only


LAYout:REMove[:WINDow]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REMove[:WINDow]
LAYout:REMove[:WINDow] <WindowName>

This command removes a window from the display.

Parameters:
<WindowName>

String containing the name of the window.

In the default state, the name of the window is its index.

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Event


LAYout:REPLace[:WINDow]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:REPLace[:WINDow]
LAYout:REPLace[:WINDow] <WindowName>,<WindowType>

This command replaces the window type (for example from "Diagram" to "Result Summary") of an already existing window while keeping its position, index and window name.

To add a new window, use the LAYout:​ADD[:​WINDow]? command.

Parameters:
<WindowName>

String containing the name of the existing window.

By default, the name of a window is the same as its index. To determine the name and index of all active windows, use the LAYout:​CATalog[:​WINDow]? query.

<WindowType>

Type of result display you want to use in the existing window.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Example: LAY:REPL:WIND '1',MTAB

Replaces the result display in window 1 with a marker table.

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:SPLitter

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:SPLitter
LAYout:SPLitter <Index1>,<Index2>,<Position>

This command changes the position of a splitter and thus controls the size of the windows on each side of the splitter.

As opposed to the DISPlay[:​WINDow<n>]:​SIZE command, the LAYout:SPLitter changes the size of all windows to either side of the splitter permanently, it does not just maximize a single window temporarily.

Note that windows must have a certain minimum size. If the position you define conflicts with the minimum size of any of the affected windows, the command will not work, but does not return an error.

SmartGrid coordinates for remote control of the splitters
Parameters:
<Index1>

The index of one window the splitter controls.

<Index2>

The index of a window on the other side of the splitter.

<Position>

New vertical or horizontal position of the splitter as a fraction of the screen area (without channel and status bar and softkey menu).

The point of origin (x = 0, y = 0) is in the lower left corner of the screen. The end point (x = 100, y = 100) is in the upper right corner of the screen. (See figure "SmartGrid coordinates for remote control of the splitters".)

The direction in which the splitter is moved depends on the screen layout. If the windows are positioned horizontally, the splitter also moves horizontally. If the windows are positioned vertically, the splitter also moves vertically.

Range: 0 to 100
Example: LAY:SPL 1,3,50

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Table') to the center (50%) of the screen, i.e. in the figure above, to the left.

Example: LAY:SPL 1,4,70

Moves the splitter between window 1 ('Frequency Sweep') and 3 ('Marker Peak List') towards the top (70%) of the screen.

The following commands have the exact same effect, as any combination of windows above and below the splitter moves the splitter vertically.

LAY:SPL 3,2,70
LAY:SPL 4,1,70
LAY:SPL 2,1,70
Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .


LAYout:WINDow<n>:ADD?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:ADD? <Direction>,<WindowType>

This command adds a measurement window to the display. Note that with this command, the suffix <n> determines the existing window next to which the new window is added, as opposed to LAYout:​ADD[:​WINDow]?, for which the existing window is defined by a parameter.

To replace an existing window, use the LAYout:​WINDow<n>:​REPLace command.

This command is always used as a query so that you immediately obtain the name of the new window as a result.

Parameters:
<Direction>
LEFT | RIGHt | ABOVe | BELow
<WindowType>

Type of measurement window you want to add.

See LAYout:​ADD[:​WINDow]? for a list of available window types.

Return values:
<NewWindowName>

When adding a new window, the command returns its name (by default the same as its number) as a result.

Example: LAY:WIND1:ADD? LEFT,MTAB

Result:

'2'

Adds a new window named '2' with a marker table to the left of window 1.

Example:

See "Example 1: Adding and Arranging Windows" .

Example:

See "Example 2: Replacing and Removing Windows" .

Usage: Query only


LAYout:WINDow<n>:IDENtify?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:IDENtify?

This command queries the name of a particular display window (indicated by the <n> suffix).

Note: to query the index of a particular window, use the LAYout:​IDENtify[:​WINDow]? command.

Return values:
<WindowName> | String containing the name of a window. In the default state, the name of the window is its index.
Usage: | Query only


LAYout:WINDow<n>:REMove

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REMove

This command removes the window specified by the suffix <n> from the display.

The result of this command is identical to the LAYout:​REMove[:​WINDow] command.

Usage: Event


LAYout:WINDow<n>:REPLace

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring the Result Display > Working with Windows in the Display > LAYout:WINDow<n>:REPLace
LAYout:WINDow<n>:REPLace <WindowType>

This command changes the window type of an existing window (specified by the suffix <n>).

The result of this command is identical to the LAYout:​REPLace[:​WINDow] command.

To add a new window, use the LAYout:​WINDow<n>:​ADD? command.

Parameters:
<WindowType>

Type of measurement window you want to replace another one with.

See LAYout:​ADD[:​WINDow]? for a list of available window types.


Configuring and Performing Sweeps

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps
Configuring and Performing Sweeps

When the MCGD application is activated, a continuous sweep is performed automatically. However, you can stop and start a new measurement any time.

Furthermore, you can perform a sequence of measurements using the Sequencer (see "Multiple Measurement Channels and Sequencer Function").

Useful commands for configuring sweeps described elsewhere:
  • [SENSe:​]AVERage:​COUNt
Remote commands exclusive to
List of Commands
ABORt
INITiate:CONMeas
INITiate:CONTinuous
INITiate[:IMMediate]
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
SYSTem:SEQuencer
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?


ABORt

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > ABORt
ABORt

This command aborts a current measurement and resets the trigger system.

To prevent overlapping execution of the subsequent command before the measurement has been aborted successfully, use the *OPC? or *WAI command after ABOR and before the next command.

For details see "Preventing Overlapping Execution" .

To abort a sequence of measurements by the Sequencer, use the INITiate:​SEQuencer:​ABORt command.

Note on blocked remote control programs:

If a sequential command cannot be completed, for example because a triggered sweep never receives a trigger, the remote control program will never finish and the remote channel to the R&S FSW is blocked for further commands. In this case, you must interrupt processing on the remote channel first in order to abort the measurement.

To do so, send a "Device Clear" command from the control instrument to the R&S FSW on a parallel channel to clear all currently active remote channels. Depending on the used interface and protocol, send the following commands:

  • Visa: viClear()
  • GPIB: ibclr()
  • RSIB: RSDLLibclr()

Now you can send the ABORt command on the remote channel performing the measurement.

Example: | ABOR;:INIT:IMM Aborts the current measurement and immediately starts a new one.
Example: | ABOR;*WAI INIT:IMM Aborts the current measurement and starts a new one once abortion has been completed.
Usage: | SCPI confirmed


INITiate:CONMeas

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > INITiate:CONMeas
INITiate:CONMeas

This command restarts a (single) measurement that has been stopped (using INIT:CONT OFF) or finished in single sweep mode.

The measurement is restarted at the beginning, not where the previous measurement was stopped.

As opposed to INITiate[:​IMMediate], this command does not reset traces in maxhold, minhold or average mode. Therefore it can be used to continue measurements using maxhold or averaging functions.

Manual operation: See "Continue Single Sweep"


INITiate:CONTinuous

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > INITiate:CONTinuous
INITiate:CONTinuous <State>

This command controls the sweep mode.

Note that in single sweep mode, you can synchronize to the end of the measurement with *OPC, *OPC? or *WAI. In continuous sweep mode, synchronization to the end of the measurement is not possible. Thus, it is not recommended that you use continuous sweep mode in remote control, as results like trace data or markers are only valid after a single sweep end synchronization.

For details on synchronization see "Command Sequence and Synchronization"

If the sweep mode is changed for a measurement channel while the Sequencer is active (see INITiate:​SEQuencer:​IMMediate) the mode is only considered the next time the measurement in that channel is activated by the Sequencer.

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

Continuous sweep

OFF | 0

Single sweep

*RST: 1
Example: INIT:CONT OFF

Switches the sweep mode to single sweep.

INIT:CONT ON

Switches the sweep mode to continuous sweep.

Manual operation: See "Continuous Sweep/RUN CONT"


INITiate[:IMMediate]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > INITiate[:IMMediate]
INITiate[:IMMediate]

This command starts a (single) new measurement.

With sweep count or average count > 0, this means a restart of the corresponding number of measurements. With trace mode MAXHold, MINHold and AVERage, the previous results are reset on restarting the measurement.

You can synchronize to the end of the measurement with *OPC, *OPC? or *WAI.

For details on synchronization see "Command Sequence and Synchronization"

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Single Sweep/ RUN SINGLE"


INITiate:SEQuencer:ABORt

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > INITiate:SEQuencer:ABORt
INITiate:SEQuencer:ABORt

This command stops the currently active sequence of measurements. The Sequencer itself is not deactivated, so you can start a new sequence immediately using INITiate:​SEQuencer:​IMMediate.

To deactivate the Sequencer use SYSTem:​SEQuencer.

Usage: Event


INITiate:SEQuencer:IMMediate

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:IMMediate

This command starts a new sequence of measurements by the Sequencer. Its effect is similar to the INITiate[:​IMMediate] command used for a single measurement.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .

Usage: Event


INITiate:SEQuencer:MODE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > INITiate:SEQuencer:MODE
INITiate:SEQuencer:MODE <Mode>

This command selects the way the R&S FSW application performs measurements sequentially.

Before this command can be executed, the Sequencer must be activated (see SYSTem:​SEQuencer).

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Note: In order to synchronize to the end of a sequential measurement using *OPC, *OPC? or *WAI you must use SINGle Sequence mode.

For details on the Sequencer see "The Sequencer Concept" .

For details on synchronization see "Command Sequence and Synchronization"

Parameters:
<Mode>
SINGle

Each measurement is performed once (regardless of the channel's sweep mode), considering each channels' sweep count, until all measurements in all active channels have been performed.

CONTinuous

The measurements in each active channel are performed one after the other, repeatedly (regardless of the channel's sweep mode), in the same order, until the Sequencer is stopped.

CDEFined

First, a single sequence is performed. Then, only those channels in continuous sweep mode (INIT:CONT ON) are repeated.

*RST: CONTinuous
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single sequence mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

Example:

See "Programming Example: Performing a Sequence of Measurements" .

Example:

See "Programming Example: Analyzing MSR Signals" .


SYSTem:SEQuencer

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > SYSTem:SEQuencer
SYSTem:SEQuencer <State>

This command turns the Sequencer on and off. The Sequencer must be active before any other Sequencer commands (INIT:SEQ...) are executed, otherwise an error will occur.

For details on the Sequencer see "The Sequencer Concept" .

A detailed programming example is provided in "Programming Example: Performing a Sequence of Measurements" .

Parameters:
<State>
ON | OFF | 0 | 1
ON | 1

The Sequencer is activated and a sequential measurement is started immediately.

OFF | 0

The Sequencer is deactivated. Any running sequential measurements are stopped. Further Sequencer commands (INIT:SEQ...) are not available.

*RST: 0
Example: SYST:SEQ ON

Activates the Sequencer.

INIT:SEQ:MODE SING

Sets single Sequencer mode so each active measurement will be performed once.

INIT:SEQ:IMM

Starts the sequential measurements.

SYST:SEQ OFF
Example:

See "Programming Example: Performing a Sequence of Measurements" .


[SENSe:]SWEep:COUNt

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > [SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt <SweepCount>

This command defines the number of sweeps the R&S FSW uses to average traces.

During calibration measurements, the phase and amplitude values are averaged over the defined number of sweeps.

In case of continuous sweeps, the R&S FSW calculates the moving average over the average count.

In case of single sweep measurements, the R&S FSW stops the measurement and calculates the average after the average count has been reached.

Parameters:
<SweepCount>

If you set a sweep count of 0 or 1, the R&S FSW performs one single sweep in single sweep mode.

In continuous sweep mode, if the sweep count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 32767
*RST: | 0
Example: SWE:COUN 64

Sets the number of sweeps to 64.

INIT:CONT OFF

Switches to single sweep mode.

INIT;*WAI

Starts a sweep and waits for its end.

Usage: SCPI confirmed
Manual operation: See "Sweep Count"


[SENSe:]SWEep:COUNt:CURRent?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Configuring and Performing Sweeps > [SENSe:]SWEep:COUNt:CURRent?
[SENSe:]SWEep:COUNt:CURRent?

This query returns the current number of started sweeps or measurements. This command is only available if a sweep count value is defined and the instrument is in single sweep mode.

Example: | SWE:COUNt 64 Sets sweep count to 64 INIT:CONT OFF Switches to single sweep mode INIT Starts a sweep (without waiting for the sweep end!) SWE:COUN:CURR? Queries the number of started sweeps
Usage: | Query only


Retrieving Results

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results
Retrieving Results

The following commands are required to retrieve the results in a remote environment.

Contents
  • Retrieving Marker Results
  • Retrieving Trace Results


Retrieving Marker Results

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Marker Results
Retrieving Marker Results
Useful commands for retrieving results described elsewhere:
  • CALCulate<n>:​DELTamarker<m>:​X
  • CALCulate<n>:​MARKer<m>:​X
Remote commands exclusive to retrieving marker results:
List of Commands
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:MARKer<m>:Y?


CALCulate<n>:DELTamarker<m>:X:RELative?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:X:RELative?

This command queries the relative position of a delta marker on the x-axis.

If necessary, the command activates the delta marker first.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | CALC:DELT3:X:REL? Outputs the frequency of delta marker 3 relative to marker 1 or relative to the reference position.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:DELTamarker<m>:Y?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>:Y?

This command queries the relative position of a delta marker on the y-axis.

If necessary, the command activates the delta marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

The unit depends on the application of the command.

Return values:
<Position> | Position of the delta marker in relation to the reference marker or the fixed reference.
Example: | INIT:CONT OFF Switches to single sweep mode. INIT;*WAI Starts a sweep and waits for its end. CALC:DELT2 ON Switches on delta marker 2. CALC:DELT2:Y? Outputs measurement value of delta marker 2.
Usage: | Query only
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


CALCulate<n>:MARKer<m>:Y?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Marker Results > CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>:Y?

This command queries the position of a marker on the y-axis.

If necessary, the command activates the marker first.

To get a valid result, you have to perform a complete measurement with synchronization to the end of the measurement before reading out the result. This is only possible for single sweeps. See also INITiate:​CONTinuous.

Return values:
<Result> | Result at the marker position.
Example: | INIT:CONT OFF Switches to single measurement mode. CALC:MARK2 ON Switches marker 2. INIT;*WAI Starts a measurement and waits for the end. CALC:MARK2:Y? Outputs the measured value of marker 2.
Usage: | Query only
Manual operation: | See "Marker Table" See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"


Retrieving Trace Results

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Trace Results
Retrieving Trace Results

The following remote commands are required to retrieve the trace results in a remote environment.

List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:LENGth?
FORMat[:DATA]
MMEMory:STORe:MCGD:MEAS
TRACe<n>[:DATA]?
TRACe<n>[:DATA]:X?


DISPlay[:WINDow<n>]:TRACe<t>:LENGth?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Trace Results > DISPlay[:WINDow<n>]:TRACe<t>:LENGth?
DISPlay[:WINDow<n>]:TRACe<t>:LENGth?

Queries the trace length.

Return values:
<TraceLength> | Number of trace points
Usage: | Query only


FORMat[:DATA]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Trace Results > FORMat[:DATA]
FORMat[:DATA] <Format>

This command selects the data format that is used for transmission of trace data from the R&S FSW to the controlling computer.

Note that the command has no effect for data that you send to the R&S FSW. The R&S FSW automatically recognizes the data it receives, regardless of the format.

Parameters:
<Format>
ASCii

ASCii format, separated by commas.

This format is almost always suitable, regardless of the actual data format. However, the data is not as compact as other formats may be.

REAL,32

32-bit IEEE 754 floating-point numbers in the "definite length block format".

In the Spectrum application, the format setting REAL is used for the binary transmission of trace data.

For I/Q data, 8 bytes per sample are returned for this format setting.

*RST: ASCII
Example: FORM REAL,32
Example:

See "Data Acquisition via the Optional Digital Baseband Interface (-B17)" .

Usage: SCPI confirmed


MMEMory:STORe:MCGD:MEAS

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Trace Results > MMEMory:STORe:MCGD:MEAS
MMEMory:STORe:MCGD:MEAS <File>

This command stores the current measurement results (all active traces in all windows, including calibration traces) to the selected file.

Setting parameters:
<File> | path and file name of the .csv file that contains the measured data
Usage: | Setting only
Manual operation: | See "Storing Measurement Results"


TRACe<n>[:DATA]?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]?
TRACe<n>[:DATA]? <Trace>

This command queries current trace data and measurement results for the specified window. For each of the measurement points (number is determined by record length, see [SENSe:​]RLENgth?) the power level, phase or group delay value is returned.

Query parameters:
<Trace> | TRACE1 | TRACE2 | TRACE3 | TRACE4 Defines the trace whose data is returned.
Example: | TRAC3:DATA? TRACE1 Returns the measured values for trace 1 in window 3.
Usage: | Query only


TRACe<n>[:DATA]:X?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Retrieving Results > Retrieving Trace Results > TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]:X? <TraceNumber>

This command queries the horizontal trace data for each sweep point in the specified window, for example the frequency in frequency domain or the time in time domain measurements.

Query parameters:
<TraceNumber> | Trace number. TRACE1 | ... | TRACE4
Example: | TRAC3:X? TRACE1 Returns the x-values for trace 1 in window 3.
Usage: | Query only


Analyzing Multi-Carrier Group Delay Measurements

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements
Analyzing Multi-Carrier Group Delay Measurements

The following commands are required to analyze MCGD measurements in a remote environment.

Contents
  • Configuring Standard Traces
  • Setting Up Individual Markers
  • General Marker Settings
  • Searching for Peaks and Positioning the Marker
  • Zooming into the Display


Configuring Standard Traces

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Configuring Standard Traces
Configuring Standard Traces
Useful commands for trace configuration described elsewhere
  • DISPlay[:​WINDow<n>]:​TRACe:​Y:​SPACing
  • DISPlay[:​WINDow<n>]:​TRACe:​Y[:​SCALe]
Remote commands exclusive to trace configuration
List of Commands
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:SMOothing:APERture
DISPlay[:WINDow<n>]:TRACe<t>:SMOothing[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]AVERage<n>:TYPE


DISPlay[:WINDow<n>]:TRACe<t>:MODE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE <Mode>

This command selects the trace mode.

In case of max hold, min hold or average trace mode, you can set the number of single measurements with "Sweep Count". Note that synchronization to the end of the measurement is possible only in single sweep mode.

For more information see "Analyzing Several Traces - Trace Mode" .

Parameters:
<Mode>
WRITe

Overwrite mode: the trace is overwritten by each sweep. This is the default setting.

AVERage

The average is formed over several sweeps. The "Sweep/Average Count" determines the number of averaging procedures.

MAXHold

The maximum value is determined over several sweeps and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is greater than the previous one.

MINHold

The minimum value is determined from several measurements and displayed. The R&S FSW saves the sweep result in the trace memory only if the new value is lower than the previous one.

VIEW

The current contents of the trace memory are frozen and displayed.

BLANk

Hides the selected trace.

*RST: Trace 1: WRITe, Trace 2-6: BLANk
Example: INIT:CONT OFF

Switching to single sweep mode.

SWE:COUN 16

Sets the number of measurements to 16.

DISP:TRAC3:MODE WRIT

Selects clear/write mode for trace 3.

INIT;*WAI

Starts the measurement and waits for the end of the measurement.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Manual operation: See "Mode"


DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous <State>

This command turns an automatic reset of a trace on and off after a parameter has changed.

The reset works for trace modes min hold, max hold and average.

Note that the command has no effect if critical parameters like the span have been changed to avoid invalid measurement results

Parameters:
<State>
ON

The automatic reset is off.

OFF

The automatic reset is on.

*RST: OFF
Example: DISP:WIND:TRAC3:MODE:HCON ON

Switches off the reset function.

Manual operation: See "Hold"


DISPlay[:WINDow<n>]:TRACe<t>:SMOothing:APERture

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:SMOothing:APERture
DISPlay[:WINDow<n>]:TRACe<t>:SMOothing:APERture <Percentage>

This command defines the degree (aperture) of the trace smoothing, if DISPlay[:​WINDow<n>]:​TRACe<t>:​SMOothing[:​STATe] TRUE.

This setting is only available for Group Delay results.

Parameters:
<Percentage>
Range: | 1 to 50
*RST: | 2
Default unit: | PCT
Example:

DISP3:TRAC2:SMO:APER 5

Defines an aperture of 5% for trace 2 in window 3 (assuming this is a Group Delay result display).

Manual operation: See "Smoothing (Group Delay only)"


DISPlay[:WINDow<n>]:TRACe<t>:SMOothing[:STATe]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>:SMOothing[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>:SMOothing[:STATe] <State>

This command turns trace smoothing for a particular trace on and off.

If enabled, the Group Delay trace is smoothed by the value specified using DISPlay[:​WINDow<n>]:​TRACe<t>:​SMOothing:​APERture.

This setting is only available for Group Delay results.

For more information see "Trace Smoothing".

Parameters:
<State>
ON | OFF
*RST: OFF
Example:

DISP3:TRAC2:SMO ON

Turns on trace smoothing for trace 2 in window 3 (assuming this is a Group Delay result display).

Usage: SCPI confirmed
Manual operation: See "Smoothing (Group Delay only)"


DISPlay[:WINDow<n>]:TRACe<t>[:STATe]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Configuring Standard Traces > DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe] <State>

This command turns a trace on and off.

The measurement continues in the background.

Parameters:
<State>
ON | OFF | 0 | 1
*RST: Trace 1: 1, Trace 2-4: 0
Example: DISP:TRAC3 ON
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Trace 1/Trace 2/Trace 3/Trace 4"
See "Trace 1/Trace 2/Trace 3/Trace 4 (Softkeys)"


[SENSe:]AVERage:COUNt

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Configuring Standard Traces > [SENSe:]AVERage:COUNt
[SENSe:]AVERage:COUNt <AverageCount>

This command defines the number of sweeps that the application uses to average traces.

In case of continuous sweeps, the application calculates the moving average over the average count.

In case of single sweep measurements, the application stops the measurement and calculates the average after the average count has been reached.

Parameters:
<AverageCount>

If you set an average count of 0 or 1, the application performs one single sweep in single sweep mode.

In continuous sweep mode, if the average count is set to 0, a moving average over 10 sweeps is performed.

Range: | 0 to 32767
*RST: | 0
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Average Count"


[SENSe:]AVERage<n>[:STATe<t>]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Configuring Standard Traces > [SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]AVERage<n>[:STATe<t>] <State>

This command turns averaging for a particular trace in a particular window on and off.

Parameters:
<State>
ON | OFF
Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed


[SENSe:]AVERage<n>:TYPE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Configuring Standard Traces > [SENSe:]AVERage<n>:TYPE
[SENSe:]AVERage<n>:TYPE <Mode>

This command selects the trace averaging mode.

Parameters:
<Mode>
VIDeo

The logarithmic power values are averaged.

LINear

The power values are averaged before they are converted to logarithmic values.

POWer

The power level values are converted into unit Watt prior to averaging. After the averaging, the data is converted back into its original unit.

*RST: VIDeo
Example: AVER:TYPE LIN

Switches to linear average calculation.

Example:

See "Programming Example: Performing a Basic Frequency Sweep" .

Usage: SCPI confirmed
Manual operation: See "Average Mode"


Setting Up Individual Markers

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers
Setting Up Individual Markers

The following commands define the position of markers in the diagram.

List of Commands
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X


CALCulate<n>:DELTamarker:AOFF

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:AOFF

This command turns all delta markers off.

Example: | CALC:DELT:AOFF Turns all delta markers off.
Usage: | Event


CALCulate<n>:DELTamarker<m>:LINK

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:LINK <State>

This command links delta marker <m> to marker 1.

If you change the horizontal position (x-value) of marker 1, delta marker <m> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2:LINK ON
Manual operation: See "Linking to Another Marker"


CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2> <State>

This command links delta marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, delta marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT4:LINK:TO:MARK2 ON

Links the delta marker 4 to the marker 2.

Manual operation: See "Linking to Another Marker"


CALCulate<n>:DELTamarker:MODE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker:MODE <Mode>

This command defines whether the position of a delta marker is provided as an absolute value or relative to a reference marker. Note that when the position of a delta marker is queried, the result is always an absolute value (see CALCulate<n>:​DELTamarker<m>:​X)!

Parameters:
<Mode>
ABSolute

Delta marker position in absolute terms.

RELative

Delta marker position in relation to a reference marker.

*RST: RELative
Example: CALC:DELT:MODE ABS

Absolute delta marker position.


CALCulate<n>:DELTamarker<m>:MREF

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:MREF <Reference>

This command selects a reference marker for a delta marker other than marker 1.

Parameters:
<Reference> | 1 to 16 Selects markers 1 to 16 as the reference.
Example: | CALC:DELT3:MREF 2 Specifies that the values of delta marker 3 are relative to marker 2.
Manual operation: | See "Reference Marker"


CALCulate<n>:DELTamarker<m>[:STATe]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m>[:STATe] <State>

This command turns delta markers on and off.

If necessary, the command activates the delta marker first.

No suffix at DELTamarker turns on delta marker 1.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:DELT2 ON

Turns on delta marker 2.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:DELTamarker<m>:TRACe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:TRACe <Trace>

This command selects the trace a delta marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> | Trace number the marker is assigned to.
Example: | CALC:DELT2:TRAC 2 Positions delta marker 2 on trace 2.


CALCulate<n>:DELTamarker<m>:X

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X <Position>

This command moves a delta marker to a particular coordinate on the x-axis.

If necessary, the command activates the delta marker and positions a reference marker to the peak power.

Parameters:
<Position> | Numeric value that defines the marker position on the x-axis. The unit is s.
Example: | CALC:DELT:X? Outputs the absolute x-value of delta marker 1.
Manual operation: | See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta" See "Marker Position (X-value)"


CALCulate<n>:MARKer<m>:AOFF

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:AOFF

This command turns all markers off.

Example: | CALC:MARK:AOFF Switches off all markers.
Usage: | Event
Manual operation: | See "All Markers Off"


CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2> <State>

This command links normal marker <m1> to any active normal marker <m2>.

If you change the horizontal position of marker <m2>, marker <m1> changes its horizontal position to the same value.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK4:LINK:TO:MARK2 ON

Links marker 4 to marker 2.

Manual operation: See "Linking to Another Marker"


CALCulate<n>:MARKer<m>[:STATe]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m>[:STATe] <State>

This command turns markers on and off. If the corresponding marker number is currently active as a deltamarker, it is turned into a normal marker.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: CALC:MARK3 ON

Switches on marker 3.

Manual operation: See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker State"
See "Marker Type"


CALCulate<n>:MARKer<m>:TRACe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:TRACe <Trace>

This command selects the trace the marker is positioned on.

Note that the corresponding trace must have a trace mode other than "Blank".

If necessary, the command activates the marker first.

Parameters:
<Trace> |
Example: | CALC:MARK3:TRAC 2 Assigns marker 3 to trace 2.
Manual operation: | See "Assigning the Marker to a Trace"


CALCulate<n>:MARKer<m>:X

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Setting Up Individual Markers > CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:X <Position>

This command moves a marker to a particular coordinate on the x-axis.

If necessary, the command activates the marker.

If the marker has been used as a delta marker, the command turns it into a normal marker.

Parameters:
<Position>

Numeric value that defines the marker position on the x-axis.

The unit is s.

Range: The range depends on the current x-axis range.
Example: CALC:MARK2:X 1.7MHz

Positions marker 2 to frequency 1.7 MHz.

Manual operation: See "Marker Table"
See "Marker 1 / Marker 2 / Marker 3 / … Marker 16,/ Marker Norm/Delta"
See "Marker Position (X-value)"


General Marker Settings

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > General Marker Settings
General Marker Settings

The following commands control general marker functionality.

List of Commands
DISPlay:MTABle
CALCulate<n>:MARKer<m>:LINK


DISPlay:MTABle

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > General Marker Settings > DISPlay:MTABle
DISPlay:MTABle <DisplayMode>

This command turns the marker table on and off.

Parameters:
<DisplayMode>
ON

Turns the marker table on.

OFF

Turns the marker table off.

AUTO

Turns the marker table on if 3 or more markers are active.

*RST: AUTO
Example: DISP:MTAB ON

Activates the marker table.

Manual operation: See "Marker Table Display"


CALCulate<n>:MARKer<m>:LINK

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > General Marker Settings > CALCulate<n>:MARKer<m>:LINK
CALCulate<n>:MARKer<m>:LINK <State>

This command sets whether all markers will be linked across all display windows or queries the current setting.

Parameters:
<State> |
Manual operation: | See "Linked Markers"


Searching for Peaks and Positioning the Marker

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker
Searching for Peaks and Positioning the Marker

The following remote commands are required to search for peaks and position the marker on a trace.

Contents
  • Searching for Peaks
  • Positioning Markers
  • Positioning Delta Markers


Searching for Peaks

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Searching for Peaks
Searching for Peaks
List of Commands
CALCulate<n>:MARKer:PEXCursion


CALCulate<n>:MARKer:PEXCursion

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Searching for Peaks > CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer:PEXCursion <Excursion>

This command defines the peak excursion.

The peak excursion sets the requirements for a peak to be detected during a peak search.

The unit depends on the measurement.

Application/Result display | Unit
Spectrum | dB
MCGD | dBm, DEG, RAD, S, MS, US, NS, PS, SC
Parameters:
<Excursion>

The excursion is the distance to a trace maximum that must be attained before a new maximum is recognized, or the distance to a trace minimum that must be attained before a new minimum is recognized

Range: | 0 to 80 dB (MCGD: 60 dBm)
*RST: | 6.0
Manual operation: See "Peak Excursion"


Positioning Markers

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Markers
Positioning Markers

The following commands position markers on the trace.

Useful commands for positioning markers described elsewhere:
  • CALCulate<n>:​DELTamarker<m>:​X
Remote commands exclusive to positioning markers
List of Commands
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:RIGHt


CALCulate<n>:MARKer<m>:MAXimum:LEFT

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:LEFT

This command moves a marker to the next lower peak.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MAXimum:NEXT

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:NEXT

This command moves a marker to the next lower peak.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]

This command moves a marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:MARKer<m>:MAXimum:RIGHt

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum:RIGHt

This command moves a marker to the next lower peak.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:LEFT

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:LEFT

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:MARKer<m>:MINimum:NEXT

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:NEXT

This command moves a marker to the next minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:MARKer<m>:MINimum[:PEAK]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum[:PEAK]

This command moves a marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:MARKer<m>:MINimum:RIGHt

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Markers > CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum:RIGHt

This command moves a marker to the next minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Positioning Delta Markers

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Delta Markers
Positioning Delta Markers

The following commands position delta markers on the trace.

Useful commands for positioning delta markers described elsewhere:
  • CALCulate<n>:​MARKer<m>:​X
Remote commands exclusive to positioning delta markers
List of Commands
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt


CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT

This command moves a delta marker to the next higher value.

The search includes only measurement values to the left of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT

This command moves a marker to the next higher value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Peak"


CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]

This command moves a delta marker to the highest level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Peak Search"


CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt

This command moves a delta marker to the next higher value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:LEFT

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:LEFT

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


CALCulate<n>:DELTamarker<m>:MINimum:NEXT

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT

This command moves a marker to the next higher minimum value.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak" See "Search Next Minimum"


CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]

This command moves a delta marker to the minimum level.

If the marker is not yet active, the command first activates the marker.

Usage: | Event
Manual operation: | See "Search Minimum"


CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Searching for Peaks and Positioning the Marker > Positioning Delta Markers > CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt

This command moves a delta marker to the next higher minimum value.

The search includes only measurement values to the right of the current marker position.

Usage: | Event
Manual operation: | See "Search Mode for Next Peak"


Zooming into the Display

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Zooming into the Display
Zooming into the Display
Contents
  • Using the Single Zoom
  • Using the Multiple Zoom


Using the Single Zoom

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Zooming into the Display > Using the Single Zoom
Using the Single Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:STATe


DISPlay[:WINDow<n>]:ZOOM:AREA

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Single Zoom"


DISPlay[:WINDow<n>]:ZOOM:STATe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Zooming into the Display > Using the Single Zoom > DISPlay[:WINDow<n>]:ZOOM:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe <State>

This command turns the zoom on and off.

Parameters:
<State>
ON | OFF
*RST: OFF
Example: DISP:ZOOM ON

Activates the zoom mode.

Manual operation: See "Single Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Using the Multiple Zoom

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Zooming into the Display > Using the Multiple Zoom
Using the Multiple Zoom
List of Commands
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA <x1>,<y1>,<x2>,<y2>

This command defines the zoom area for a multiple zoom.

To define a zoom area, you first have to turn the zoom on.

1 = origin of coordinate system (x1 = 0, y1 = 0)
2 = end point of system (x2 = 100, y2= 100)
3 = zoom area (e.g. x1 = 60, y1 = 30, x2 = 80, y2 = 75)
Suffix:
<zoom>
1...4

Selects the zoom window.

Parameters:
<x1>,<y1>, <x2>,<y2>

Diagram coordinates in % of the complete diagram that define the zoom area.

The lower left corner is the origin of coordinate system. The upper right corner is the end point of the system.

Range: | 0 to 100
Default unit: | PCT
Manual operation: See "Multiple Zoom"


DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Analyzing Multi-Carrier Group Delay Measurements > Zooming into the Display > Using the Multiple Zoom > DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe <State>

This command turns the mutliple zoom on and off.

Suffix:
<zoom>
1...4

Selects the zoom window.

If you turn off one of the zoom windows, all subsequent zoom windows move up one position.

Parameters:
<State>
ON | OFF
*RST: OFF
Manual operation: See "Multiple Zoom"
See "Restore Original Display"
See "Deactivating Zoom (Selection mode)"


Commands for Compatibility

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility
Commands for Compatibility

The following commands are provided for compatibility to other signal analyzers only. For new remote control programs use the specified alternative commands.

To set the R&S FSW to compatible mode for previous signal analyzers, use the SYST:LANG command.

See SYSTem:​LANGuage .

List of Commands
CALCulate<n>:FEED
DISPlay[:WINDow<n>]:TYPE
[SENSe:]ADEMod:BANDwidth:DEModulation?
[SENSe:]ADEMod:BWIDth:DEModulation?
[SENSe:]ADEMod:MCPHase:METHod
[SENSe:]ADEMod:MCPHase:SPACing
[SENSe:]ADEMod:MCPHase[:STATe]
[SENSe:]ADEMod:SPECtrum:PHASe:RESult?
[SENSe:]ADEMod:SPECtrum:PHASe:TYPE
[SENSe:]ADEMod:SPECtrum:SPAN
[SENSe:]ADEMod:SPECtrum:SPAN:ZOOM
[SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum]
[SENSe:]ADEMod:SPECtrum[:MAGNitude]:RESult?
[SENSe:]ADEMod:SPECtrum[:MAGNitude][:TYPE]
[SENSe:]ADEMod:MTIMe?
[SENSe:]ADEMod:MTIMe:AUTO
[SENSe:]ADEMod:RLENgth?
[SENSe:]ADEMod:SRATe?
[SENSe:]ADEMod[:STATe]


CALCulate<n>:FEED

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > CALCulate<n>:FEED
CALCulate<n>:FEED <Evaluation>

This command selects the evaluation method of the measured data that is to be displayed in the specified window.

This command queries or sets the diagram type (for magnitude or for phase).

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Parameters:
<Evaluation>
'XFRequency:SPECtrum[:MAGNitude]'

Magnitude diagram

'XFRequency:SPECtrum:PHASe'

Phase diagram


DISPlay[:WINDow<n>]:TYPE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > DISPlay[:WINDow<n>]:TYPE
DISPlay[:WINDow<n>]:TYPE <ResultType>

This command selects the results displayed in a measurement window.

Note that this command is maintained for compatibility reasons only. Use the LAYout commands for new remote control programs (see "Working with Windows in the Display").

Parameters:
<ResultType>
<WindowType> parameter values for Multi-Carrier Group Delay (K17) mode
Parameter value | Window type
GAIN | Gain
GDELay | Group Delay
MAGNitude | Magnitude (Measurement data)
MTABle | Marker table
PHASe | Phase (Measurement data)
RMAGnitude | Magnitude (Reference data)
RPHase | Phase vs frequency (Reference data)


[SENSe:]ADEMod:BANDwidth:DEModulation?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:BANDwidth:DEModulation?
[SENSe:]ADEMod:BANDwidth:DEModulation?
[SENSe:]ADEMod:BWIDth:DEModulation?

This command queries the measurement bandwidth.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]BANDwidth:​DEMod? for new remote control programs.

Return values:
<Span>
Default unit: HZ
Usage: Query only


[SENSe:]ADEMod:MCPHase:METHod

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:MCPHase:METHod
[SENSe:]ADEMod:MCPHase:METHod <Method>

This command selects the method used for group delay measurements. As the R&S FSW MCGD application only supports orthogonal measurements, this command returns an error if the FLATtop parameter is used.

Parameters:
<Method>
ORTHogonal | FLATtop


[SENSe:]ADEMod:MCPHase:SPACing

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:MCPHase:SPACing
[SENSe:]ADEMod:MCPHase:SPACing <CarrierSpacing>

Sets/queries the carrier spacing in Hz between the multiple carriers.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]CARRier:​SPACing for new remote control programs.

Parameters:
<CarrierSpacing>
Default unit: HZ


[SENSe:]ADEMod:MCPHase[:STATe]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:MCPHase[:STATe]
[SENSe:]ADEMod:MCPHase[:STATe] <State>

This command switches to the Multi Carrier Group Delay application of the instrument or disables it.

Note that this command is maintained for compatibility reasons only. Use the INST:SEL MCGD command for new remote control programs (see INSTrument[:​SELect]).

Parameters:
<State>


[SENSe:]ADEMod:SPECtrum:PHASe:RESult?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:SPECtrum:PHASe:RESult?
[SENSe:]ADEMod:SPECtrum:PHASe:RESult? <WindowType>

This command returns the trace data of the first trace of the given type within the phase window.

Note that this command is maintained for compatibility reasons only. Use TRACe<n>[:​DATA]? for new remote control programs.

Query parameters:
<WindowType> | WRITe | AVERage | MINHold | MAXHold
Usage: | Query only


[SENSe:]ADEMod:SPECtrum:PHASe:TYPE

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:SPECtrum:PHASe:TYPE
[SENSe:]ADEMod:SPECtrum:PHASe:TYPE <Trace1>, <Trace2>, <Trace3>

This command sets the modes of the first three traces of phase windows.

Note that this command is maintained for compatibility reasons only. Use DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE for new remote control programs.

Parameters:
<Trace1> | WRITe | AVERage | MINHold | MAXHold | VIEW | OFF
<Trace2> | WRITe | AVERage | MINHold | MAXHold | VIEW | OFF
<Trace3> | WRITe | AVERage | MINHold | MAXHold | VIEW | OFF


[SENSe:]ADEMod:SPECtrum:SPAN

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:SPECtrum:SPAN
[SENSe:]ADEMod:SPECtrum:SPAN <Frequency>

Sets/queries the frequency span in Hz.

Note that this command is maintained for compatibility reasons only. Use the [SENSe:​]FREQuency:​SPAN command for new remote control programs.

Parameters:
<Frequency>
Default unit: HZ


[SENSe:]ADEMod:SPECtrum:SPAN:ZOOM

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:SPECtrum:SPAN:ZOOM
[SENSe:]ADEMod:SPECtrum:SPAN:ZOOM <Value>

This command sets the span.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]FREQuency:​SPAN for new remote control programs.

Parameters:
<Value>
Default unit: HZ


[SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum]
[SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum] <Value>

This command sets the span.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]FREQuency:​SPAN for new remote control programs.

Parameters:
<Value>
Default unit: HZ


[SENSe:]ADEMod:SPECtrum[:MAGNitude]:RESult?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:SPECtrum[:MAGNitude]:RESult?
[SENSe:]ADEMod:SPECtrum[:MAGNitude]:RESult? <WindowType>

This command returns the trace data of the first trace of the given type within the magnitude window.

Note that this command is maintained for compatibility reasons only. Use TRACe<n>[:​DATA]? for new remote control programs.

Query parameters:
<WindowType> | WRITe | AVERage | MINHold | MAXHold
Usage: | Query only


[SENSe:]ADEMod:SPECtrum[:MAGNitude][:TYPE]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:SPECtrum[:MAGNitude][:TYPE]
[SENSe:]ADEMod:SPECtrum[:MAGNitude][:TYPE] <Trace1>, <Trace2>, <Trace3>

This command sets the modes of the first three traces of magnitude windows.

Note that this command is maintained for compatibility reasons only. Use DISPlay[:​WINDow<n>]:​TRACe<t>:​MODE for new remote control programs.

Parameters:
<Trace1> | WRITe | AVERage | MINHold | MAXHold | VIEW | OFF
<Trace2> | WRITe | AVERage | MINHold | MAXHold | VIEW | OFF
<Trace3> | WRITe | AVERage | MINHold | MAXHold | VIEW | OFF


[SENSe:]ADEMod:MTIMe?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:MTIMe?
[SENSe:]ADEMod:MTIMe? <MeasTime>

This command queries or sets the measurement time.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]MTIMe? for new remote control programs.

Parameters:
<MeasTime>
Default unit: S
Usage: Query only


[SENSe:]ADEMod:MTIMe:AUTO

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:MTIMe:AUTO
[SENSe:]ADEMod:MTIMe:AUTO <MeasTimeAutoMode>

This command enables or disables automatic measurement time selection.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]MTIMe:​AUTO for new remote control programs.

Parameters:
<MeasTimeAutoMode>


[SENSe:]ADEMod:RLENgth?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:RLENgth?
[SENSe:]ADEMod:RLENgth?

This command returns the record length set up for current measurement settings.

Note that this command is maintained for compatibility reasons only. Use the [SENSe:​]RLENgth? command for new remote control programs.

Return values:
<SampleCount> |
Usage: | Query only


[SENSe:]ADEMod:SRATe?

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod:SRATe?
[SENSe:]ADEMod:SRATe?

This command returns the sample rate set up for current measurement settings.

Note that this command is maintained for compatibility reasons only. Use [SENSe:​]SRATe? for new remote control programs.

Return values:
<SampleRate> |
Usage: | Query only


[SENSe:]ADEMod[:STATe]

Multi-Carrier Group Delay (R&S FSW-K17) > Remote Commands to Perform Multi-Carrier Group Delay Measurements > Commands for Compatibility > [SENSe:]ADEMod[:STATe]
[SENSe:]ADEMod[:STATe] <State>

This command switches to the Analog Demodulation application or disables it.

Note that this command is maintained for compatibility reasons only. Use the INST:SEL ADEM command for new remote control programs.

Parameters:
<State>


Annex

Multi-Carrier Group Delay (R&S FSW-K17) > Annex
Annex
Contents
  • Reference: ASCII File Export Format
  • Reference: CSV File Export Format


Reference: ASCII File Export Format

Multi-Carrier Group Delay (R&S FSW-K17) > Annex > Reference: ASCII File Export Format
Reference: ASCII File Export Format

Trace data (both measurement and reference traces) can be exported to a file in ASCII format for further evaluation in other applications

The file consists of the header containing important scaling parameters and a data section containing the trace data.

Generally, the format of this ASCII file can be processed by spreadsheet calculation programs, e.g. MS-Excel. Different language versions of evaluation programs may require a different handling of the decimal point. Thus you can define the decimal separator to be used (decimal point or comma, see "Decimal Separator").

The data of the file header consist of two columns, separated by a semicolon: parameter name; numeric value. The data section contains the measured data in two columns, which are also separated by a semicolon.

ASCII file format for trace export
File contents | Description
Header data
Type;R&S FSW; | Instrument model
Version;1.30; | Firmware version
Date;20.Jan 2012; | Date of data set storage
Mode;MCGD | Channel type
Ref Level;0; | Reference level
Level offset;0; | Reference level offset
Rf Att;10; | Input attenuation
El Att;0; | Electronic attentuation
Center Freq;10000000;Hz | Center frequency
Freq Offset;0;Hz | Frequency offset
Span;10000000;Hz | Frequency range
Carrier Spacing,10000000;Hz | Distance between two carriers
Meas Time;0.00003128125;s | Measurement time
Group Delay;Absolute; | Value type for group delay
Carrier Offset;AUTO; | Auto mode for carrier offset
Carrier Offset;0;Hz | Carrier offset value
Sweep Count;0; | Number of sweeps set
Preamplifier;OFF | Preamplifier status
Window;1 Magnitude; | Window name containing trace
Trace 1:;; | Selected trace
Trace Mode;Clear Write | Display mode of trace: CLR/WRITE,AVERAGE,MAXHOLD,MINHOLD
x-Axis;Linear; | Scaling of x-axis linear (LIN) or logarithmic (LOG)
Start;95000000;Hz Stop;105000000;Hz | Start/stop value of the display range
x-Unit;Hz; | Unit of x values: Hz with span > 0; s with span = 0; dBm/dB with statistics measurements
y-Axis;Linear; | Scaling of y-axis linear (LIN) or logarithmic (LOG)
Level Range;100;dB | Display range in y direction. Unit: dB with x-axis LOG, % with x-axis LIN
Ref Position;100; % | Position of reference value referred to diagram limits (0 % = lower edge)
Ref Value;0.0;dBm | Reference value
y-Unit;dBm; | Unit of y values: dB*/V/A/W depending on the selected unit with y-axis LOG or % with y-axis LIN
Data section
Values; 1001; | Number of measurement points
95000000;-20.5 96000000;-20.3 97000000;-24.2 ...;...; | Measured values: <x value>, <y value>


Reference: CSV File Export Format

Multi-Carrier Group Delay (R&S FSW-K17) > Annex > Reference: CSV File Export Format
Reference: CSV File Export Format

Measurement results and calibration data can be exported to a file in CSV format for further evaluation in other applications. Note that as opposed to the "Export Trace to ASCII File", storing the measurement results in csv format includes all traces in all windows, not just one single trace.

The file consists of the header containing important parameters and a data section containing the measurement data.

Generally, the format of this CSV file can be processed by spreadsheet calculation programs, e.g. MS-Excel. Different language versions of evaluation programs may require a different handling of the decimal point. Thus you can define the decimal separator to be used (decimal point or comma; see "Decimal Separator").

The data of the file header consist of three columns; each separated by a semicolon: parameter name; numeric value; basic unit. The data section contains the measured data in two columns, which are also separated by a semicolon.

CSV file format for calibration data export
File contents | Description
Header data
Type;R&S FSW-K17 Reference Calibration; | Type of data
Version;1.40; | Firmware version
Date;20.Jan 2012; | Date of data set storage
Mode;MCGD | Channel type
Center Freq;10000000;Hz | Center frequency
Freq Offset;0;Hz | Frequency offset
Span;10000000;Hz | Frequency range
Number of Carriers;51; | Number of carriers
Carrier Spacing;10000000;Hz | Distance between two carriers
Meas Time;0.00003128125;s | Measurement time
Sweep Count;0 | Sweep count
Trace type;Amplitude Reference Calibration | Data source and result display (Magnitude Reference)
x-Unit;Hz; | Unit of x values
y-Unit;V; | Unit of y values
Data section
Values; 51; | Number of measurement points
95000000;-20.5 96000000;-20.3 97000000;-24.2 ...;...; | Measured values: <x value>; <y value>
CSV file format for measurement data export
File contents | Description
Header data
Type;R&S FSW; | Instrument model
Version;1.30; | Firmware version
Date;20.Jan 2012; | Date of data set storage
Mode;MCGD;DB1.00 | Channel type; database version
Ref Level;0; | Reference level
Level offset;0; | Reference level offset
Rf Att;10; | Input attenuation
El Att;0; | Electronic attentuation
Center Freq;10000000;Hz | Center frequency
Freq Offset;0;Hz | Frequency offset
Span;10000000;Hz | Frequency range
Number of Carriers;51; | Number of carriers
Carrier Spacing;10000000;Hz | Distance between two carriers
Meas Time;0.00003128125;s | Measurement time
Group Delay;Absolute; | Value type for group delay
Carrier Offset;AUTO; | Auto mode for carrier offset
Carrier Offset;0;Hz | Carrier offset value
Sweep Count;0; | Number of sweeps set
Preamplifier;OFF | Preamplifier status
Number of windows | Number of windows included in export
Data section for individual window
Window;1 Magnitude | Name of first window (= result display)
Data section for individual trace
Trace 1;; | First trace
Trace Mode;Clear Write; | Display mode of trace: CLR/WRITE;AVERAGE;MAXHOLD;MINHOLD
x-Axis;Linear; | Scaling of x-axis: linear (LIN) or logarithmic (LOG)
Start;95000000;Hz Stop;105000000;Hz | Start/stop value of the display range
x-Unit;Hz; | Unit of x values: Hz with span > 0; s with span = 0; dBm/dB with statistics measurements
y-Axis;Linear; | Scaling of y-axis linear (LIN) or logarithmic (LOG)
Level Range;100;dB | Display range in y direction. Unit: dB with x-axis LOG; % with x-axis LIN
Ref Position;100; % | Position of reference value referred to diagram limits (0 % = lower edge)
Ref Value;0.0;dBm | Reference value
y-Unit;dBm; | Unit of y values: dB*/V/A/W depending on the selected unit with y-axis LOG or % with y-axis LIN
Values; 1001; | Number of measurement points
95000000;-20.5 96000000;-20.3 97000000;-24.2 ...;...; | Measured values: <x value>; <y value>
Data section for individual trace
Trace 2;; | Next trace in same window
... |
Data section for individual window
Window;2 Phase; | Name of next window
Data section for individual trace |
Trace 1;; | First trace
... |


List of Remote Commands (MC Group Delay)

Multi-Carrier Group Delay (R&S FSW-K17) > List of Remote Commands (MC Group Delay)
List of Remote Commands (MC Group Delay)
[SENSe:]ADEMod:BANDwidth:DEModulation?
[SENSe:]ADEMod:BWIDth:DEModulation?
[SENSe:]ADEMod:MCPHase:METHod
[SENSe:]ADEMod:MCPHase:SPACing
[SENSe:]ADEMod:MCPHase[:STATe]
[SENSe:]ADEMod:MTIMe:AUTO
[SENSe:]ADEMod:MTIMe?
[SENSe:]ADEMod:RLENgth?
[SENSe:]ADEMod:SPECtrum:PHASe:RESult?
[SENSe:]ADEMod:SPECtrum:PHASe:TYPE
[SENSe:]ADEMod:SPECtrum:SPAN
[SENSe:]ADEMod:SPECtrum:SPAN:ZOOM
[SENSe:]ADEMod:SPECtrum:SPAN[:MAXimum]
[SENSe:]ADEMod:SPECtrum[:MAGNitude]:RESult?
[SENSe:]ADEMod:SPECtrum[:MAGNitude][:TYPE]
[SENSe:]ADEMod:SRATe?
[SENSe:]ADEMod[:STATe]
[SENSe:]ADJust:CONFigure:DURation
[SENSe:]ADJust:CONFigure:DURation:MODE
[SENSe:]ADJust:CONFigure:HYSTeresis:LOWer
[SENSe:]ADJust:CONFigure:HYSTeresis:UPPer
[SENSe:]ADJust:LEVel
[SENSe:]AVERage:COUNt
[SENSe:]AVERage<n>:TYPE
[SENSe:]AVERage<n>[:STATe<t>]
[SENSe:]BANDwidth:DEMod?
[SENSe:]BWIDth:DEMod?
[SENSe:]CARRier:COUNt
[SENSe:]CARRier:OFFSet:MODE
[SENSe:]CARRier:OFFSet?
[SENSe:]CARRier:SPACing
[SENSe:]FREQuency:CENTer
[SENSe:]FREQuency:CENTer:STEP
[SENSe:]FREQuency:CENTer:STEP:AUTO
[SENSe:]FREQuency:CENTer:STEP:LINK
[SENSe:]FREQuency:CENTer:STEP:LINK:FACTor
[SENSe:]FREQuency:OFFSet
[SENSe:]FREQuency:SPAN
[SENSe:]MTIMe:AUTO
[SENSe:]MTIMe?
[SENSe:]RLENgth?
[SENSe:]SRATe?
[SENSe:]SWEep:COUNt
[SENSe:]SWEep:COUNt:CURRent?
ABORt
CALCulate:GRPDelay:MODE
CALCulate<n>:DELTamarker:AOFF
CALCulate<n>:DELTamarker:MODE
CALCulate<n>:DELTamarker<m>:LINK
CALCulate<n>:DELTamarker<m>:MAXimum:LEFT
CALCulate<n>:DELTamarker<m>:MAXimum:NEXT
CALCulate<n>:DELTamarker<m>:MAXimum:RIGHt
CALCulate<n>:DELTamarker<m>:MAXimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MINimum:LEFT
CALCulate<n>:DELTamarker<m>:MINimum:NEXT
CALCulate<n>:DELTamarker<m>:MINimum:RIGHt
CALCulate<n>:DELTamarker<m>:MINimum[:PEAK]
CALCulate<n>:DELTamarker<m>:MREF
CALCulate<n>:DELTamarker<m>:TRACe
CALCulate<n>:DELTamarker<m>:X
CALCulate<n>:DELTamarker<m>:X:RELative?
CALCulate<n>:DELTamarker<m>:Y?
CALCulate<n>:DELTamarker<m>[:STATe]
CALCulate<n>:DELTamarker<m1>:LINK:TO:MARKer<m2>
CALCulate<n>:FEED
CALCulate<n>:MARKer:PEXCursion
CALCulate<n>:MARKer<m>:AOFF
CALCulate<n>:MARKer<m>:LINK
CALCulate<n>:MARKer<m>:MAXimum:LEFT
CALCulate<n>:MARKer<m>:MAXimum:NEXT
CALCulate<n>:MARKer<m>:MAXimum:RIGHt
CALCulate<n>:MARKer<m>:MAXimum[:PEAK]
CALCulate<n>:MARKer<m>:MINimum:LEFT
CALCulate<n>:MARKer<m>:MINimum:NEXT
CALCulate<n>:MARKer<m>:MINimum:RIGHt
CALCulate<n>:MARKer<m>:MINimum[:PEAK]
CALCulate<n>:MARKer<m>:TRACe
CALCulate<n>:MARKer<m>:X
CALCulate<n>:MARKer<m>:Y?
CALCulate<n>:MARKer<m>[:STATe]
CALCulate<n>:MARKer<m1>:LINK:TO:MARKer<m2>
CALibration:MCGD
CALibration:MCGD:STATe?
DIAGnostic:SERVice:NSOurce
DISPlay:FORMat
DISPlay:MTABle
DISPlay[:WINDow<n>]:SIZE
DISPlay[:WINDow<n>]:TRACe:Y:SPACing
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MAXimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MINimum
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:MODE
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:PDIVision
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RLEVel:OFFSet
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RPOSition
DISPlay[:WINDow<n>]:TRACe:Y[:SCALe]:RVALue
DISPlay[:WINDow<n>]:TRACe<t>:LENGth?
DISPlay[:WINDow<n>]:TRACe<t>:MODE
DISPlay[:WINDow<n>]:TRACe<t>:MODE:HCONtinuous
DISPlay[:WINDow<n>]:TRACe<t>:SMOothing:APERture
DISPlay[:WINDow<n>]:TRACe<t>:SMOothing[:STATe]
DISPlay[:WINDow<n>]:TRACe<t>[:STATe]
DISPlay[:WINDow<n>]:TYPE
DISPlay[:WINDow<n>]:ZOOM:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:AREA
DISPlay[:WINDow<n>]:ZOOM:MULTiple<zoom>:STATe
DISPlay[:WINDow<n>]:ZOOM:STATe
FORMat[:DATA]
INITiate:CONMeas
INITiate:CONTinuous
INITiate:SEQuencer:ABORt
INITiate:SEQuencer:IMMediate
INITiate:SEQuencer:MODE
INITiate[:IMMediate]
INPut:ATTenuation
INPut:ATTenuation:AUTO
INPut:ATTenuation:PROTection:RESet
INPut:COUPling
INPut:EATT
INPut:EATT:AUTO
INPut:EATT:STATe
INPut:FILTer:HPASs[:STATe]
INPut:FILTer:YIG[:STATe]
INPut:GAIN:STATe
INPut:GAIN[:VALue]
INPut:IMPedance
INPut:SELect
INSTrument:CREate:DUPLicate
INSTrument:CREate:REPLace
INSTrument:CREate[:NEW]
INSTrument:DELete
INSTrument:LIST?
INSTrument:REName
INSTrument[:SELect]
LAYout:ADD[:WINDow]?
LAYout:CATalog[:WINDow]?
LAYout:IDENtify[:WINDow]?
LAYout:REMove[:WINDow]
LAYout:REPLace[:WINDow]
LAYout:SPLitter
LAYout:WINDow<n>:ADD?
LAYout:WINDow<n>:IDENtify?
LAYout:WINDow<n>:REMove
LAYout:WINDow<n>:REPLace
MMEMory:LOAD:MCGD:RCALibration
MMEMory:STORe:MCGD:MEAS
MMEMory:STORe:MCGD:RCALibration
OUTPut:TRIGger<port>:DIRection
OUTPut:TRIGger<port>:LEVel
OUTPut:TRIGger<port>:OTYPe
OUTPut:TRIGger<port>:PULSe:IMMediate
OUTPut:TRIGger<port>:PULSe:LENGth
SYSTem:PRESet:CHANnel[:EXECute]
SYSTem:SEQuencer
TRACe<n>[:DATA]:X?
TRACe<n>[:DATA]?
TRIGger[:SEQuence]:DTIMe
TRIGger[:SEQuence]:HOLDoff[:TIME]
TRIGger[:SEQuence]:IFPower:HOLDoff
TRIGger[:SEQuence]:IFPower:HYSTeresis
TRIGger[:SEQuence]:LEVel:IFPower
TRIGger[:SEQuence]:LEVel:IQPower
TRIGger[:SEQuence]:LEVel:RFPower
TRIGger[:SEQuence]:LEVel[:EXTernal<port>]
TRIGger[:SEQuence]:RFPower:HOLDoff
TRIGger[:SEQuence]:SLOPe
TRIGger[:SEQuence]:SOURce
UNIT:ANGLe


Legal Notice

R&S®FSW-K17
Multi-Carrier Group Delay Measurement

© 2014 Rohde & Schwarz GmbH & Co. KG

Mühldorfstr. 15, 81671 München, Germany

Phone: +49 89 41 29 - 0

Fax: +49 89 41 29 12 164

E-mail: info@rohde-schwarz.com

Internet: www.rohde-schwarz.com

Subject to change – Data without tolerance limits is not binding.

R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.

Trade names are trademarks of the owners.